Port Forwarding (NAT) with Dual WAN - Same Port for both Connections



  • So, I've got Dual WAN load balancing setup (followed the wiki guide) and it seems to be working great. However, I'm having trouble getting port forwarding to work. I'm new to this, so it's probably something simple that I'm screwing up. Basically, I want to route incoming connections on port 7500 (which I use for bittorrent) on either of my WAN connections (WAN & OPT1) to my local IP address 10.0.0.2.  I've setup a NAT rule for both connections that seems like it should do this. It in turn creates firewall rules for both the WAN and OPT1 connections. Still, when I go here: http://www.utorrent.com/testport.php?port=7500 the port says it isn't forwarded and trackers seem to think I'm not connectable.

    I've attached the NAT setup:

    an example of the firewall rule for WAN (same rule exists for OPT1):

    and also my LAN firewall rules:

    Not sure what is going wrong here? Am I not setting up the forwarding right? Is something incorrectly setup for the LAN rules for load balancing?

    Thanks for any help you can give.








  • Hmmm. It seems that the forwarding is working for the WAN connection, but not for OPT1. Do I need any additional settings for OPT1? When I looked in the firewall log, incoming connections on port 7500 on the OPT1 connection are being denied for some reason, even though there is a firewall rule setup.



  • I am curious because I am looking at a similar setup.  Did you figure out the proper configuration?  Thank you.



  • Try setting your NAT rules to (ext:any)

    Also your bittorrent machine will need full access to the internet as you won't know which port the other people are using. people will connect to you on 7500 but you will connect to them on something else, which of your rules is this?



Locked