Alix 2D13 unable to upgrade from 2.3.3



  • Hi !

    I have tried and tried … to upgrade to 2.3.4 and now to 2.3.5 from 2.3.3 but the process ends abnorally everytime.
    The console log :
    Enter an option: 13

    /usr/local/libexec/pfSense-upgrade: gnid: not found

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Unlocking package pfSense-kernel-pfSense_wrap... done.
    **** WARNING ****
    Duplicate slice required!!

    Before starting the upgrade process, the currently mounted nanobsd partition
    needs to be cloned to the secondary partition, where the update will happen

    After installation a reboot will be required to switch partition.

    Proceed with upgrade? (y/N) y
    mount: /dev/ufs/pfsense0: Device busy

    Cleaning secondary partition... done.
    Duplicating current slice... done.
    Restoring slice label... done.
    Testing duplicated partition integrity... done.
    Mounting second partition to run upgrade... done.
    Removing resolv.conf symlink from upgrade partition... done.
    Copying resolv.conf to upgrade partition... done.
    Downloading upgrade packages...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (125 candidates): .......... done
    Processing candidates (125 candidates):
    pkg-static: unbound has a missing dependency: libevent2
    Processing candidates (125 candidates).......... done
    Checking integrity... done (2 conflicting)
      - oniguruma6-6.4.0 [pfSense] conflicts with oniguruma5-5.9.6_1 [installed] on /usr/local/bin/onig-config
      - pecl-rrd1-1.1.3 [pfSense] conflicts with pecl-rrd-1.1.3_4 [installed] on /usr/local/lib/php/20131226/rrd.so
    Checking integrity… done (0 conflicting)
    The following 98 package(s) will be affected (of 0 checked):

    Installed packages to be REMOVED:
            oniguruma5-5.9.6_1
            pecl-rrd-1.1.3_4

    New packages to be INSTALLED:
            python2: 2_3 [pfSense]
            libevent: 2.1.8 [pfSense]
            oniguruma6: 6.4.0 [pfSense]
            pecl-rrd1: 1.1.3 [pfSense]
            wpa_supplicant: 2.6_2 [pfSense]
            hostapd: 2.6_1 [pfSense]
            libidn2: 2.0.4 [pfSense]
            libunistring: 0.9.7 [pfSense]

    Installed packages to be UPGRADED:
            unbound: 1.6.0 -> 1.6.6 [pfSense]
            uclcmd: 0.1_1 -> 0.1_2 [pfSense]
            strongswan: 5.5.1 -> 5.6.0 [pfSense]
            sqlite3: 3.15.1_1 -> 3.20.1_1 [pfSense]
            smartmontools: 6.5_1 -> 6.5_2 [pfSense]
            rrdtool: 1.6.0_1 -> 1.7.0_1 [pfSense]
            python27: 2.7.13_1 -> 2.7.14 [pfSense]
            php56-zlib: 5.6.30 -> 5.6.31 [pfSense]
            php56-xmlwriter: 5.6.30 -> 5.6.31 [pfSense]
            php56-xmlreader: 5.6.30 -> 5.6.31 [pfSense]
            php56-xml: 5.6.30 -> 5.6.31 [pfSense]
            php56-tokenizer: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvshm: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvsem: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvmsg: 5.6.30 -> 5.6.31 [pfSense]
            php56-sqlite3: 5.6.30 -> 5.6.31 [pfSense]
            php56-sockets: 5.6.30 -> 5.6.31 [pfSense]
            php56-simplexml: 5.6.30 -> 5.6.31 [pfSense]
            php56-shmop: 5.6.30 -> 5.6.31 [pfSense]
            php56-session: 5.6.30 -> 5.6.31 [pfSense]
            php56-readline: 5.6.30 -> 5.6.31 [pfSense]
            php56-posix: 5.6.30 -> 5.6.31 [pfSense]
            php56-pfSense-module: 0.13 -> 0.13_1 [pfSense]
            php56-pdo_sqlite: 5.6.30 -> 5.6.31 [pfSense]
            php56-pdo: 5.6.30 -> 5.6.31 [pfSense]
            php56-pcntl: 5.6.30 -> 5.6.31 [pfSense]
            php56-openssl: 5.6.30 -> 5.6.31 [pfSense]
            php56-opcache: 5.6.30 -> 5.6.31 [pfSense]
            php56-mcrypt: 5.6.30 -> 5.6.31 [pfSense]
            php56-mbstring: 5.6.30 -> 5.6.31_1 [pfSense]
            php56-ldap: 5.6.30 -> 5.6.31 [pfSense]
            php56-json: 5.6.30 -> 5.6.31 [pfSense]
            php56-hash: 5.6.30 -> 5.6.31 [pfSense]
            php56-gettext: 5.6.30 -> 5.6.31 [pfSense]
            php56-filter: 5.6.30 -> 5.6.31 [pfSense]
            php56-dom: 5.6.30 -> 5.6.31 [pfSense]
            php56-curl: 5.6.30 -> 5.6.31 [pfSense]
            php56-ctype: 5.6.30 -> 5.6.31 [pfSense]
            php56-bz2: 5.6.30 -> 5.6.31 [pfSense]
            php56-bcmath: 5.6.30 -> 5.6.31 [pfSense]
            php56: 5.6.30 -> 5.6.31 [pfSense]
            php-xdebug: 2.4.1_1 -> 2.5.0 [pfSense]
            pftop: 0.7_7 -> 0.7_8 [pfSense]
            pfSense-rc: 2.3.3_1 -> 2.3.5 [pfSense-core]
            pfSense-kernel-pfSense_wrap: 2.3.1_5 -> 2.3.5 [pfSense-core]
            pfSense-default-config-serial: 2.3.3_1 -> 2.3.5 [pfSense-core]
            pfSense-base-nanobsd: 2.3.3_1 -> 2.3.5 [pfSense-core]
            pfSense-Status_Monitoring: 1.6.1_3 -> 1.6.3 [pfSense]
            pfSense: 2.3.1_5 -> 2.3.5 [pfSense]
            perl5: 5.24.1.r4_1 -> 5.24.3 [pfSense]
            pcre: 8.39_1 -> 8.40_1 [pfSense]
            openvpn23: 2.3.14 -> 2.3.17 [pfSense]
            openldap-client: 2.4.44 -> 2.4.45 [pfSense]
            ntp: 4.2.8p9_1 -> 4.2.8p10_2 [pfSense]
            nginx: 1.10.2_3,2 -> 1.12.1_2,2 [pfSense]
            mpd5: 5.8 -> 5.8_2 [pfSense]
            lzo2: 2.09 -> 2.10_1 [pfSense]
            libzmq4: 4.1.5 -> 4.2.2 [pfSense]
            libssh2: 1.8.0,2 -> 1.8.0,3 [pfSense]
            libsodium: 1.0.11_1 -> 1.0.12 [pfSense]
            libnghttp2: 1.18.0 -> 1.26.0 [pfSense]
            libiconv: 1.14_10 -> 1.14_11 [pfSense]
            libedit: 3.1.20150325_2,1 -> 3.1.20170329_2,1 [pfSense]
            ldns: 1.6.17_5 -> 1.7.0_1 [pfSense]
            isc-dhcp43-server: 4.3.5 -> 4.3.6_1 [pfSense]
            isc-dhcp43-relay: 4.3.5 -> 4.3.6 [pfSense]
            isc-dhcp43-client: 4.3.5 -> 4.3.6 [pfSense]
            ipmitool: 1.8.17_1 -> 1.8.18_1 [pfSense]
            gmp: 5.1.3_3 -> 6.1.2 [pfSense]
            glib: 2.46.2_4 -> 2.50.2_6,1 [pfSense]
            expat: 2.2.0_1 -> 2.2.1 [pfSense]
            dnsmasq: 2.76,1 -> 2.78,1 [pfSense]
            dmidecode: 3.0 -> 3.1_1 [pfSense]
            dhcp6: 20080615.1 -> 20080615.2 [pfSense]
            curl: 7.53.0 -> 7.56.1 [pfSense]
            clog: 1.0.1 -> 1.0.1_1 [pfSense]
            ca_root_nss: 3.28.1 -> 3.32.1 [pfSense]
            bind-tools: 9.11.0P3 -> 9.11.2 [pfSense]

    Installed packages to be REINSTALLED:
            vstr-1.0.15_1 [pfSense]
            norm-1.5r6 [pfSense]
            nettle-3.3 [pfSense]
            libxml2-2.9.4 [pfSense]
            libucl-0.8.0 [pfSense]
            libmcrypt-2.5.8_3 [pfSense]
            libltdl-2.4.6 [pfSense]
            json-c-0.12.1 [pfSense]
            idnkit-1.0_6 [pfSense]
            check_reload_status-0.0.7 [pfSense] (direct dependency changed: libevent)

    Number of packages to be removed: 2
    Number of packages to be installed: 8
    Number of packages to be upgraded: 78
    Number of packages to be reinstalled: 10

    The process will require 12 MiB more space.

    Upgrading pfSense kernel…
    Checking integrity... done (0 conflicting)
    The following 2 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
            pfSense-kernel-pfSense_wrap: 2.3.1_5 -> 2.3.5 [pfSense-core]
            pfSense-rc: 2.3.3_1 -> 2.3.5 [pfSense-core]

    Number of packages to be upgraded: 2
    [1/2] Upgrading pfSense-rc from 2.3.3_1 to 2.3.5…
    [1/2] Extracting pfSense-rc-2.3.5: …. done
    [2/2] Upgrading pfSense-kernel-pfSense_wrap from 2.3.1_5 to 2.3.5…
    [2/2] Extracting pfSense-kernel-pfSense_wrap-2.3.5: …....... done
    ===> Keeping a copy of current kernel in /boot/kernel.old

    Upgrading necessary packages...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (123 candidates): .......... done
    Processing candidates (123 candidates):
    pkg-static: unbound has a missing dependency: libevent2
    Processing candidates (123 candidates).......... done
    Checking integrity... done (2 conflicting)
      - oniguruma6-6.4.0 [pfSense] conflicts with oniguruma5-5.9.6_1 [installed] on /usr/local/bin/onig-config
      - pecl-rrd1-1.1.3 [pfSense] conflicts with pecl-rrd-1.1.3_4 [installed] on /usr/local/lib/php/20131226/rrd.so
    Checking integrity… done (0 conflicting)
    The following 96 package(s) will be affected (of 0 checked):

    Installed packages to be REMOVED:
            oniguruma5-5.9.6_1
            pecl-rrd-1.1.3_4

    New packages to be INSTALLED:
            python2: 2_3 [pfSense]
            libevent: 2.1.8 [pfSense]
            oniguruma6: 6.4.0 [pfSense]
            pecl-rrd1: 1.1.3 [pfSense]
            wpa_supplicant: 2.6_2 [pfSense]
            hostapd: 2.6_1 [pfSense]
            libidn2: 2.0.4 [pfSense]
            libunistring: 0.9.7 [pfSense]

    Installed packages to be UPGRADED:
            unbound: 1.6.0 -> 1.6.6 [pfSense]
            uclcmd: 0.1_1 -> 0.1_2 [pfSense]
            strongswan: 5.5.1 -> 5.6.0 [pfSense]
            sqlite3: 3.15.1_1 -> 3.20.1_1 [pfSense]
            smartmontools: 6.5_1 -> 6.5_2 [pfSense]
            rrdtool: 1.6.0_1 -> 1.7.0_1 [pfSense]
            python27: 2.7.13_1 -> 2.7.14 [pfSense]
            php56-zlib: 5.6.30 -> 5.6.31 [pfSense]
            php56-xmlwriter: 5.6.30 -> 5.6.31 [pfSense]
            php56-xmlreader: 5.6.30 -> 5.6.31 [pfSense]
            php56-xml: 5.6.30 -> 5.6.31 [pfSense]
            php56-tokenizer: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvshm: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvsem: 5.6.30 -> 5.6.31 [pfSense]
            php56-sysvmsg: 5.6.30 -> 5.6.31 [pfSense]
            php56-sqlite3: 5.6.30 -> 5.6.31 [pfSense]
            php56-sockets: 5.6.30 -> 5.6.31 [pfSense]
            php56-simplexml: 5.6.30 -> 5.6.31 [pfSense]
            php56-shmop: 5.6.30 -> 5.6.31 [pfSense]
            php56-session: 5.6.30 -> 5.6.31 [pfSense]
            php56-readline: 5.6.30 -> 5.6.31 [pfSense]
            php56-posix: 5.6.30 -> 5.6.31 [pfSense]
            php56-pfSense-module: 0.13 -> 0.13_1 [pfSense]
            php56-pdo_sqlite: 5.6.30 -> 5.6.31 [pfSense]
            php56-pdo: 5.6.30 -> 5.6.31 [pfSense]
            php56-pcntl: 5.6.30 -> 5.6.31 [pfSense]
            php56-openssl: 5.6.30 -> 5.6.31 [pfSense]
            php56-opcache: 5.6.30 -> 5.6.31 [pfSense]
            php56-mcrypt: 5.6.30 -> 5.6.31 [pfSense]
            php56-mbstring: 5.6.30 -> 5.6.31_1 [pfSense]
            php56-ldap: 5.6.30 -> 5.6.31 [pfSense]
            php56-json: 5.6.30 -> 5.6.31 [pfSense]
            php56-hash: 5.6.30 -> 5.6.31 [pfSense]
            php56-gettext: 5.6.30 -> 5.6.31 [pfSense]
            php56-filter: 5.6.30 -> 5.6.31 [pfSense]
            php56-dom: 5.6.30 -> 5.6.31 [pfSense]
            php56-curl: 5.6.30 -> 5.6.31 [pfSense]
            php56-ctype: 5.6.30 -> 5.6.31 [pfSense]
            php56-bz2: 5.6.30 -> 5.6.31 [pfSense]
            php56-bcmath: 5.6.30 -> 5.6.31 [pfSense]
            php56: 5.6.30 -> 5.6.31 [pfSense]
            php-xdebug: 2.4.1_1 -> 2.5.0 [pfSense]
            pftop: 0.7_7 -> 0.7_8 [pfSense]
            pfSense-default-config-serial: 2.3.3_1 -> 2.3.5 [pfSense-core]
            pfSense-base-nanobsd: 2.3.3_1 -> 2.3.5 [pfSense-core]
            pfSense-Status_Monitoring: 1.6.1_3 -> 1.6.3 [pfSense]
            pfSense: 2.3.1_5 -> 2.3.5 [pfSense]
            perl5: 5.24.1.r4_1 -> 5.24.3 [pfSense]
            pcre: 8.39_1 -> 8.40_1 [pfSense]
            openvpn23: 2.3.14 -> 2.3.17 [pfSense]
            openldap-client: 2.4.44 -> 2.4.45 [pfSense]
            ntp: 4.2.8p9_1 -> 4.2.8p10_2 [pfSense]
            nginx: 1.10.2_3,2 -> 1.12.1_2,2 [pfSense]
            mpd5: 5.8 -> 5.8_2 [pfSense]
            lzo2: 2.09 -> 2.10_1 [pfSense]
            libzmq4: 4.1.5 -> 4.2.2 [pfSense]
            libssh2: 1.8.0,2 -> 1.8.0,3 [pfSense]
            libsodium: 1.0.11_1 -> 1.0.12 [pfSense]
            libnghttp2: 1.18.0 -> 1.26.0 [pfSense]
            libiconv: 1.14_10 -> 1.14_11 [pfSense]
            libedit: 3.1.20150325_2,1 -> 3.1.20170329_2,1 [pfSense]
            ldns: 1.6.17_5 -> 1.7.0_1 [pfSense]
            isc-dhcp43-server: 4.3.5 -> 4.3.6_1 [pfSense]
            isc-dhcp43-relay: 4.3.5 -> 4.3.6 [pfSense]
            isc-dhcp43-client: 4.3.5 -> 4.3.6 [pfSense]
            ipmitool: 1.8.17_1 -> 1.8.18_1 [pfSense]
            gmp: 5.1.3_3 -> 6.1.2 [pfSense]
            glib: 2.46.2_4 -> 2.50.2_6,1 [pfSense]
            expat: 2.2.0_1 -> 2.2.1 [pfSense]
            dnsmasq: 2.76,1 -> 2.78,1 [pfSense]
            dmidecode: 3.0 -> 3.1_1 [pfSense]
            dhcp6: 20080615.1 -> 20080615.2 [pfSense]
            curl: 7.53.0 -> 7.56.1 [pfSense]
            clog: 1.0.1 -> 1.0.1_1 [pfSense]
            ca_root_nss: 3.28.1 -> 3.32.1 [pfSense]
            bind-tools: 9.11.0P3 -> 9.11.2 [pfSense]

    Installed packages to be REINSTALLED:
            vstr-1.0.15_1 [pfSense]
            norm-1.5r6 [pfSense]
            nettle-3.3 [pfSense]
            libxml2-2.9.4 [pfSense]
            libucl-0.8.0 [pfSense]
            libmcrypt-2.5.8_3 [pfSense]
            libltdl-2.4.6 [pfSense]
            json-c-0.12.1 [pfSense]
            idnkit-1.0_6 [pfSense]
            check_reload_status-0.0.7 [pfSense] (direct dependency changed: libevent)

    Number of packages to be removed: 2
    Number of packages to be installed: 8
    Number of packages to be upgraded: 76
    Number of packages to be reinstalled: 10

    The process will require 12 MiB more space.
    [1/96] Upgrading python27 from 2.7.13_1 to 2.7.14…
    [1/96] Extracting python27-2.7.14: Child process pid=67724 terminated abnormally: Killed

    Locking package pfSense-kernel-pfSense_wrap… done.
    pkg-static: open(/bin/sh): No such file or directory
    pkg-static: open(/bin/sh): No such file or directory

    Does anyone can help me please ?
    Gabe



  • Try to backup your 2.3.3 settings from the webconfigurator diagnostics menu. Then make a clean install of  2.3.5. Once it is up and running restore your 2.3.3 settings from the webconfigurator diagnostics menu back.

    If your box has a 64 bit processor you can go for 2.4.1 instead of 2.3.5.



  • Thank you. Hope the backup/restore will work perfectly ;-)

    Alix2D13 is 32 bits only. I'will buy apu2c4 to replace it and install 2.4 then 2.5 …


Log in to reply