Toggling WIFI in iOS helps…!?



  • Greetings,

    using the unbound DNS resolver for my local WIFI devices I sometimes have to toggle the WIFI connection in iOS.

    Usually everything is resolving, but sometimes, all of a sudden some domain names do no longer resolve. Toggling WIFI in iOS off and on again instantly cures it. No need to restart safari or anything.

    Anyone has an idea what this is about and how to resolve (:) this?

    Thanks!



  • I have had to do this as well…

    I am running the latest IOS 11.1(upgrade if you are not!). I am also using Unbound with forwarding NOT enabled i.e. I have not entered OpenDNS or Googles DNS IPs as alternative DNS servers.

    I found toggling WIFI on and off helped when I was playing/testing Unbound settings. i.e. when I added OpenDNS and enabled forwarding.

    Not absolutely sure but if you have DNS forwarding enabled(and using google, OpenDNS or other) it might be going back and forth between Unbound and OpenDNS on pfSense. This might be confusing IOS.

    I noticed with the recent IOS upgrades, DNS became more "configurable" with IOS. Go to your WIFI network on IOS and hit the "i" next to your WIFI. Scroll down to DNS and you will see it is set to either "Automatic" or "Manual"...mine works fine on Automatic (It shows my local network as my DNS server which is how I want it). If you select Manual you can add DNS servers (Not sure you want OpenDNS or Google but maybe add them there?

    I hope that helps you trouble shoot or solve your issue...

    V



  • Interestingly enough, I have noticed this as well, though I'm not sure the issue is with Unbound.  In my case I have seen this occur with both forwarding enabled and disabled.  What makes you think Unbound is to blame?  Could the issue be with iOS?

    Thanks in advance for any additional insight that can be provided.



  • I am not sure I am qualified to say it is an unbound or a IOS issue, but I have seen strange issues specifically with my IOS and Mac devices. Toggling my IOS wifi after any changes to my DNS settings in pfSense seemed to work.

    Keep in mind my current rule setup forces DNS via unbound…

    Different but still Apple related, most recently, after a reboot of my pfsense box I am unable to go online with any Apple product, I then go online with a non-apple product no problem. After that my Apple products are able to go online....while I trouble shooted this scenario I saw alerts in my firewall from IOS devices on port 123 and 5223(I think this was the port?).


  • LAYER 8 Global Moderator

    123 would ntp, that 5223 port is Apple Push Notification Service (APNS)…

    I have not seen any such issues with my IOS devices ipad (air2) and iphone (7) running 11.1 while wifes iphone is stuck on 10.3.3 (5c)..

    What exactly are you using for wifi?  Card in pfsense?  Real AP (unifi? or other).. Some wifi router in AP mode?



  • I use a Unifi Pro AP…the other variable that could be causing my temporary issue is my VPN connection(recently moved my unbound to use VPN only).

    Toggling my wifi for my internet connection does not solve my recent problem(I tried this after a recent reboot) but seems Apple related. The toggling used to fix some things...


  • LAYER 8 Global Moderator

    I use unifi AP as well.. There was some bugs in the FT option, but in the current controller (5.7.3) and AP firmware (3.9.6.7613) now it is working fine for apple devices..  Not seeing any sort of issues with the 3 apple devices I have.. Pretty rock solid connections..



  • I am using an Unifi AP as well, connected to a managed switch, connected to pfsense. pfsense is doing all the work with filtering, pppoe, DHCP and resolving. I was using unbound in forwarding mode and switched it to non-forwarding now. I havent seen the resolving issue re-occuring since then. That does not mean much though as it did not happen very often anyway. I will report after some more testing…



  • I'm a complete apple household with multiple iPhones, Macbooks and some ATVs.

    I run with unbound in resolving mode and we're all up on the  iOS 11.1 and latest revs of all the MacOSes and haven't noticed any issues with Wifi. We don't use pfSense for Wifi as I have 2 other APs for that.

    Macs tends to have issues with some 5GHz wifi channels and that's the only thing I've really changed, but that tends to be that it won't connect if the channel is too high.



  • I'm also using Ubiquity AP's on my network - maybe it's a problem/bug with the AP firmware?

    One other thing that might be worth trying is to toggle the Wi-Fi Assist feature on/off on iOS to see if that helps any.


Log in to reply