Kamdelia network status firewalled



  • Is it possible to get open status in eMule/Kamdelia network? Port forwarding is not working for KAD, although ed2k status is open and all the other network apps. With D-Link DI-804 router Kamdelia network had open status.



  • There should be no problem if you forward the correct port and I guess lots of people use it successfully as there have been no complaints.

    Check your NAT and your Firewallrules. I guess something is wrong there.



  • Rules are correctly set. I was testing again and once I got open status. I try to repeat it. The related rule had logging set and took it off and now status is firewalled again. Halt or reboot might resolve it, because somehow I think rules won't update correctly. I should not have touched anything once it was working :).. but it just might be a lucky coincidence.

    Next I try clean install, because I have problems with RRD graphs and clock being fast.



  • Clean install did not help. KAD may just be very picky when deciding open or not.



  • Try the static ports option with advanced outbound NAT. Maybe this helps.



  • Ok, I'll try that. Thanks.

    Do I need to do more than just make an advanced outbound nat rule and it'll be effective or do I have to disable Ipsec passthru and enable advanced outbound nat?



  • advanced outbound nat and ipsec passthrough is either or. You can't have them both at the same time. enable advanced outbound nat and it will generate the default rule for your LAN (the one that is already in place when advanced outbound nat is disabled but hidden). Then place a rule on top of this for your Kamdelia Client and check the static Port option.



  • Thanks a million! That worked like a charm :). Is there any ill effects from what I did?

    Should I click the button "Thanks, solved", because it locks the thread? I did not find anything in the forum rules.



  • Ok, found the explanation to "solved button" http://forum.pfsense.org/index.php?topic=656.0.


Log in to reply