Video corruption during or after install of 2.4.x? Try this.

  • After much puzzlement, I have finally figured out how to get 2.4.0 and 2.4.1 to boot on my AMD radeon based hardware.

    A straight boot leads to video corruption that makes the installer completely illegible.

    Pressing escape [ESC] immediately after initial boot brings up the kernel loader parameters input screen.  If you press escape more than once, the first attempt to enter a command after the "OK" will fail, but subsequent inputs work fine.

    Enter 'gop list' without the quotes, and then hit enter.  You will see a list of numbered available video modes.  After some trial and error, I found that 'gop set 5' worked for me.  After entering 'gop set 5' without the quotes and hitting enter, the return is OK.  Then type 'boot' without the quotes, and hit enter.  When you find the correct mode, the installer will boot correctly, and you will have a fully legible screen.

    Before exiting the installer by choosing reboot, enter the shell, and use the editor of your choice to create and save a new file /boot/loader.rc.local containing a single line with 'gop set #', without the quotes, and the number # set to the numeric mode that worked for you, followed by a new line.  In my case the new file /boot/loader.rc.local contains 'gop set 5' without the quotes, followed by a new line.  Do not add your new 'gop set #' line to the existing /boot/loader.rc file, as that will not work.

    The specific hardware I am using is a Wyse Z90DW thin client which has 4GB of ram, and a 16GB SATA SSD installed.  The machine features an AMD G-T56N 1.6Ghz dual core APU.

    I hope this helps someone.


    I am now using 'gop set 8' which corresponds to 800x600x32 on my hardware.  This should support a wider array of monitors.  Gop mode 5, which corresponds to 1152x864x32, works well on my HD monitor, but will likely fail on the old 1024x768 LCD I keep around as a floating head.

    It might make sense to set 'gop set 8' as a default in /boot/loader.rc.local in the memstick installer, as this might prevent "out of range" errors when attempting to use older monitors on new hardware in the course of installation.

    I can confirm that the new install will boot and display correctly when connected to an ancient 1024x768 LCD monitor using a DVI>VGA adapter, when 'gop set 8' is configured in /boot/loader.rc.local.

    Editing the memstick installer to include a /boot/loader.rc.local file containing 'gop set 8' allows the installer to boot when connected to my old 1024x768 LCD monitor, and prevents the "out of range" error that occurs otherwise.

  • Hi Bennett,

    I encountered this on similar hardware. I did not find your solution at the time - my loss!
    I have raised a bug in RedMine for this:

    Perhaps we'll have a fix in 2.5.x!


  • Thanks bfeitell!

    I recently updated my pfsense install to a UEFI install to take advantage of the real estate of my 3840x2160 resolution monitor via the console and I had some screen tearing at the bottom which obfuscated the active command prompt. I've been searching for a solution for close to a week and had tried everything from attempting to load vesa.ko and i915kms.ko (for my Intel HD graphics), to trying to get the vidcontrol command to work, to trying to edit /boot/loader.conf with kern.vty=vt,  kern.vt.fb.default_mode="<x>x<y>", etc.

    This is the only solution that actually worked for me!

    Edit: I stand corrected. I was able to change the resolution by interrupting the boot process, but I can't get the setting to load automatically with the /boot/loader.rc.local file.</y></x>

Log in to reply