First time installation hanging



  • Hello, first time pfSense user here. I just picked up a ZOTAC ZBOX-CI327NANO-U Intel Celeron N3450 (https://www.zotac.com/us/product/mini_pcs/ci327-nano) w/8GB RAM and 120GB SSD. I seem to be getting a hang on a first time install in single-user mode. The image being used to install is pfSense-CE-memstick-2.4.1-RELEASE-amd64.img on a USB stick.

    At first it appeared to hang on the following boot line:

    Timecounter "HPET" frequency 19200000 Hz quality 950

    After then upgrading the BIOS to latest just to be sure and then enabling the "verbose" mode, I see the following

    .
    .
    .
    Timecounter "HPET" frequency 19200000 Hz quality 950
    ….(skipping a few lines starting with msi: routing...).....
    msi: routing MSI-X IRQ 262 to local APIC 2 vector 50
    msi: routing MSI-X IRQ 263 to local APIC 4 vector 49
    msi: Assigning MSI-X IRQ 256 to local APIC 0 vector 52

    Any idea on how to make it past this point? I tried disabling the other SATA drive in BIOS just for fun, no luck there.



  • i have the same zbox and had the same problems.
    i installed it in safe mode and started it in safe mode the first time.
    after that i set some options, but i dont remember them all atm. i will post my config later when i get home.



  • as mentioned in the last post, here is my /boot/loader.conf.local:

    hint.sdhci_pci.0.disabled=1
    hint.sdhci_pci.1.disabled=1
    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1
    hint.hpet.0.clock=0
    kern.ipc.nmbclusters="262144"
    hw.re.fc_setting=0
    hw.re.rxd=2048
    hw.re.txd=2048
    net.pf.states_hashsize=524288
    net.pf.source_nodes_hashsize=524288
    hw.re.rx_process_limit="-1"
    hw.re.tx_process_limit="-1"
    net.inet.tcp.syncache.hashsize="2048"
    net.inet.tcp.syncache.bucketlimit="16"
    net.inet.tcp.syncache.cachelimit="32768"
    hw.re.enable_msix=0
    hw.pci.enable_msix=0
    machdep.disable_msix_migration=1
    net.inet.tcp.tso=0
    
    


  • Thank you! I'll give this config a shot



  • Solution:
    disable 'Monitor M-Wait' in bios
    Could be under Features tab > CPU Configuration



  • @internetservices:

    Solution:
    disable 'Monitor M-Wait' in bios
    Could be under Features tab > CPU Configuration

    Confirmed that disabling Monitor M-Wait removes the boot hang I posted originally. Thanks!



  • @internetservices:

    Solution:
    disable 'Monitor M-Wait' in bios
    Could be under Features tab > CPU Configuration

    I cant seem to find this feature in my bios http://asrock.com/mb/Intel/J3455-ITX/

    Any suggestions?