PfSense installation failing



  • Hi all,

    Having an issue getting pfSense to install here

    Bought a mini pc from amazon that looked like a great little box for this.  I’ve purchased smaller types in the past, but they have issues with some of the heavier loads. 
    Regardless, the title is "QOTOM Q330G4 Mini PC for pfSense w/ 8GB RAM + 16GB SSD - Core i3, AES-NI, 4 Intel LAN, 15Watts, Industrial Mini PC Firewall Gateway Router (Q330G4-8R-16S)"
    Sounds like a good fit no?  lol

    So, I tried both of the memory stick installs (AMD64 and Netgate ADI)

    Tried the installs and no luck, so I used gparted and removed the partitions (formatted drive to FAT32 and ext4).  Came stock with Windows installed on it.  Tried installations again, same result

    AMD64 result - starts up with FreeBSD bootblock and then goes to a blank screen with a solid little block in the top left (looks like a fat cursor) and does nothing (left it for an hour once)

    Netgate ADI result - gets into installing FreeBSD and then hangs up with:

    Trying to mount root from ufs:/dev/ufs/FreeBSD_Install [ro,noatime]…
    random: unblocking device.

    Left it at this state for an hour with no change
    If I plug anything in or unplug (ethernet, usb keyboard), the system acknowleges it as you can see the connetion/disconnetion occur on the screen
    So, it’s not frozen, just halted it seems

    Some relevant info from the BIOS
    BIOS = American Megatrends Q3XXG 4.03 x64
    Intel i3-4025U
    SSD = SanDisk  i1
    Ram is 8GB DDR3
    NICs are all Intel 1211 GB

    Not sure what the issue is here!
    Any of you run in to something like this?  i’m at a loss and scouring the site (and others) is not yielding me any solutions here



  • Trying everything I can think of, I installed Ubuntu to see how that went.  It launched to the installer and I went through the prompts.
    One thing came up that I’ve never seen before prior to the actual installation going.  I said something to the effect that it’s setup for another OS and UEFI or something to that effect
    I should have written it down, but like a fool I did not.

    After the Ubuntu install, I tried the pfSense installs again - same results
    Wipe the drive - same results
    Tried installing Ubuntu again so I could write that message down and it did not come up again

    I’m not very well versed in this side of computing, but it feel to me like I have something amiss in a BIOS setting somewhere



  • I think it’s possible to install pfSense on this hardware.
    https://forum.pfsense.org/index.php?topic=132528.msg730118#msg730118
    Did you read that topic? May be you will find some tips, like bios settings.
    Also you can try VMware ESXi on it, if it runs fine just install the pfSense there.
    https://doc.pfsense.org/index.php/PfSense_on_VMware_vSphere_/_ESXi



  • Thanks w0w, I’ll read up on this thread and see where that takes me


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy