Haproxy Configuration - Local Network Access?



  • I am trying to setup Ombi (plex request) with Haproxy so I can use a domain:no port to direct to my internal IP:Port.

    I have Haproxy setup and working when outside my local area network.  However inside the network I have to use the IP:Port.  I want the domain without port to work both internally and externally.  The primary users are my family from their phones and having them keep two bookmarks (1) at home and (2) outside of home is just not effective.

    Haproxy:
    Frontend WAN IP address (via dyndns) port 80
    Backend LAN IP address port 3579

    PureNAT is enabled

    Thank you.



  • 'PureNAT is enabled' - but haproxy is a proxy, it doesn't use natting :)

    Also on the 'inside' you should be able to visit http://domain/ without issue if allowed by firewallrules. if not what happens? timeout / error? which error exactly?

    Unless you are using 'transparent client ip' feature in the backend maybe? In which case there is a requirement for server and client to be on different subnets so reply traffic is guaranteed to pass back through haproxy.



  • @PiBa:

    Unless you are using 'transparent client ip' feature in the backend maybe? In which case there is a requirement for server and client to be on different subnets so reply traffic is guaranteed to pass back through haproxy.

    That was it, I didn't realize that was enabled!



  • I've been trying to get this to work for a long time but just can't get HAproxy setup correctly with Ombi. Any chance you can do a step by step?

    Also, are you using SSL?

    Cheers,

    Zane