Upgrade Fail 2.4



  • Hi Guys,

    I'm on pfSense 2.3.4 and I need to update this to the newer version, which is 2.4.0.
    The issue is when I'm running the update, it gives me following error message: "pkg-static: https://pkg.pfsense.org/pfSense_v2_4_0_amd64-pfSense_v2_4_0/All/webfonts-0.30_13.txz: Operation timed out Failed"

    I think "pkg.pfsense.org" domain is not resolvable. How do I solve this?


  • Rebel Alliance Developer Netgate

    The pkg.pfsense.org DNS is fine (it uses SRV records, so you're probably checking it wrong). It can resolve it OK but not download the files.

    If it was a DNS problem the error would be something else.

    It looks like it's getting partway through and then failing or timing out though. If you try it again, does it fail on the same file? Is there anything else like a proxy or another firewall in front of this one that could be slowing it down or interfering?



  • You should not upgrade to 2.4.
    I tried and completely disappointed  ::) ::)



  • You should not upgrade to 2.4.
    I tried and completely disappointed

    Sorry, have to disagree completely.
    My experience migrating 20+ installations at various revisions from 2.2.5 up to 2.3.5 has been very positive.

    The only (minor) headache I ran into was a system that wouldn't auto-update from 2.3.0.
    It seemed to be locked down to a development stream and wouldn't let me change it.
    Simplest fix was to take a backup of the config.xml, reinstall from scratch and restore the backup.

    Full repair was perhaps 20min.

    Other than that it's been quite painless for me.

    Whatever you do, make sure you have a backup of your current setup.

    Just my $.02


Log in to reply