2.4.0 / 2.4.1 hang during boot at hpet0: High precision timer



  • hi,

    I've just upgraded from 2.3.x to 2.4 and unfortunately the system no longer boots – boot hangs pretty soon a the line

    hpet0: <high precision="" event="" timer="">iomem 0xfed00000...
    (see screenshot)

    I can get it to boot by going in the boot options and setting "Safe Mode" to On. Booting takes a very long time, but it succeeds. Don't know if booting in Safe mode has any drawbacks for the operation of pfSense?

    Also tried 2.4.1 -- exactly same problem.

    The system is a Zotac ZBOX CI327 nano with an Intel N3450 CPU and 2x Gigabit Ethernet. Hast been running just fine with pfSense 2.3.x so far.

    Problem now is that I need to attach monitor/keyboard in case the system reboots, and manually select Safe Mode.

    Is that boot hang a known problem that will be addressed in an update soon?

    Not sure if I should restore the system back down to 2.3 or keep booting safe mode in the mean time.

    I'll be more than happy to provide more information in case it helps figuring out and solving the issue.

    thanks

    ![2017-11-19 18_17_22-Photo - Google Photos.png](/public/imported_attachments/1/2017-11-19 18_17_22-Photo - Google Photos.png)
    ![2017-11-19 18_17_22-Photo - Google Photos.png_thumb](/public/imported_attachments/1/2017-11-19 18_17_22-Photo - Google Photos.png_thumb)</high>



  • Have you tried doing a fresh install of 2.4.1 from USB or CDROM media to see if your issue is related to upgrading or some problem between pfSense and your hardware? I've found firmware upgrades can cause problems. Would be a good opportunity to switch your filesystem to ZFS as well.



  • use hint.hpet.0.clock="0" in /boot/loader.conf.local.
    or press escape in the boot menu and then enter set hint.hpet.0.clock="0".

    edit:
    if that works, you might set all the options mentioned here:
    https://forum.pfsense.org/index.php?topic=139733.msg763901#msg763901



  • Solution:
    disable 'Monitor M-Wait' in bios
    Could be under Features tab > CPU Configuration


Log in to reply