[SOLVED] Certain Websites not working



  • I have PFSense installed on a PC for my home network. I am using CenturyLInk DSL for my ISP.

    Specs for PC:

    • i3 6100 (3.7GHz)

    • 8 GB DDR4 Ram

    • Intel Nics

    I have been using my ISP supplied leased modem in transparent bridging mode successfully for a few years. I finally got around to buying my own modem to end the monthly modem fee. The modem I got was on their approved list, but I bought it off of Amazon as a used modem. It is the Zyxel c1100z. The previous modem I was using was the Zyxel C1000z.

    Once I started using it, I noticed I was having difficulty getting certain sites to load. Consistantly I was having difficulty getting package tracking from fedex.com and ups.com as well as logging into mint.com and sporadic difficulties with netflix.com. I'm also having sporadic problems with other sites timing out, but I haven't been able to nail down which ones and when it happens consistantly.

    When I changed out modems, I also upgraded PFsense which had not been upgraded in a few months. I am currently at 2.4.2. I don't recall what I was at before, but I want to say it was a 2.3.x version.

    All of my troubleshooting has pointed me towards my problems being with PFSense. What I have tried to come to this conclusion:

    • Bought another identical modem but in new condition with identical Internet problems

    • Switched to mobile phone data signal when sites would not load over wifi, site would immediately load

    • Tried using desktop computer connected by ethernet when site would not load on device connected by wifi. Similar problems

    • Spent time with ISP support troubleshooting line. They could not find anything wrong

    • Used new modem in regular config (not in transparent bridging) as router successfully loading pages that had been not working.

    • Multiple reboots of modem

    • Multiple reboots of Pfsense computer

    • Took PFsense computer out of the network and used my old backup router (Linksys WRT54 GL with Tomato) Sites worked. Put PFSense back in network as router and sites would not work again

    The dashboard shows the following services running: DHCP Service, dpinger, ntpd, syslogd, unbound

    What information do you need from me to try to help troubleshoot my problem? I don't know a lot about networking, but just enough to get myself in trouble.

    Thank you for any help.



  • If I understand correctly the problems started after you replaced the modem right? were the sites loading fine with the ISP provided modem and pfsense?



  • Yes it was working with the previous ISP provided modem in transparent bridging mode while using an earlier version of PFSense

    The new modem when not in transparent bridging (acting as a router and modem) works fine. The new modem in transparent bridging with an old router (not PFSense) works fine.

    The new modem with updated PFSense does not work.

    Thank you



  • Hmmm, this smells like a MTU issue to me.



  • I've never changed any MTU settings before. I don't know why there would suddenly be a conflict with this. Unless there is something I don't know about here?

    Jason



  • My settings for MTU has been left blank which means it was taking what ever the default value was. I am using PPPoE. I've seen where you are supposed to use 1492 and 1500. I don't know which one to use but I've tried putting both numbers in for my MTU setting in PFsense and that didn't make any difference.



  • I seem to have found my solution

    https://doc.pfsense.org/index.php/Unable_to_Access_Some_Websites

    Step 9 seems to have done the trick:

    Check Clear invalid DF bits instead of dropping the packets on System > Advanced, Firewall/NAT tab

    Jason


Log in to reply