2.4.0 -> 2.4.2: pkg-1.10.1_1 is locked and may not be modified [SOLVED]



  • I've upgraded a few pfSense boxes through various versions including to 2.4.2 but my home system is coming up with this when trying to update:

    "pkg-1.10.1_1 is locked and may not be modified
    Failed"

    Full output below.  I've tried a reboot, and running an update from the console.  I've even read the man page on pkg but would rather get some advice before I try messing about.

    [EDIT: - Oh well, temptation called and I ran "pkg unlock pkg" and then the upgrade appeared to complete OK]

    Any advice?

    Cheers
    Jon

    
    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    >>> Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (49 candidates): .......... done
    Processing candidates (49 candidates): .......... done
    The following 51 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	wpa_supplicant: 2.6_2 [pfSense]
    	hostapd: 2.6_1 [pfSense]
    
    Installed packages to be UPGRADED:
    	radvd: 1.9.1 -> 2.17_3 [pfSense]
    	php56-zlib: 5.6.31 -> 5.6.32 [pfSense]
    	php56-xmlwriter: 5.6.31 -> 5.6.32 [pfSense]
    	php56-xmlreader: 5.6.31 -> 5.6.32 [pfSense]
    	php56-xml: 5.6.31 -> 5.6.32 [pfSense]
    	php56-tokenizer: 5.6.31 -> 5.6.32 [pfSense]
    	php56-sysvshm: 5.6.31 -> 5.6.32 [pfSense]
    	php56-sysvsem: 5.6.31 -> 5.6.32 [pfSense]
    	php56-sysvmsg: 5.6.31 -> 5.6.32 [pfSense]
    	php56-sqlite3: 5.6.31 -> 5.6.32 [pfSense]
    	php56-sockets: 5.6.31 -> 5.6.32 [pfSense]
    	php56-simplexml: 5.6.31 -> 5.6.32 [pfSense]
    	php56-shmop: 5.6.31 -> 5.6.32 [pfSense]
    	php56-session: 5.6.31 -> 5.6.32 [pfSense]
    	php56-readline: 5.6.31 -> 5.6.32 [pfSense]
    	php56-posix: 5.6.31 -> 5.6.32 [pfSense]
    	php56-pfSense-module: 0.54 -> 0.57 [pfSense]
    	php56-pdo_sqlite: 5.6.31 -> 5.6.32 [pfSense]
    	php56-pdo: 5.6.31 -> 5.6.32 [pfSense]
    	php56-pcntl: 5.6.31 -> 5.6.32 [pfSense]
    	php56-openssl: 5.6.31 -> 5.6.32 [pfSense]
    	php56-opcache: 5.6.31 -> 5.6.32 [pfSense]
    	php56-mcrypt: 5.6.31 -> 5.6.32 [pfSense]
    	php56-mbstring: 5.6.31_1 -> 5.6.32 [pfSense]
    	php56-ldap: 5.6.31 -> 5.6.32 [pfSense]
    	php56-json: 5.6.31 -> 5.6.32 [pfSense]
    	php56-hash: 5.6.31 -> 5.6.32 [pfSense]
    	php56-gettext: 5.6.31 -> 5.6.32 [pfSense]
    	php56-ftp: 5.6.31 -> 5.6.32 [pfSense]
    	php56-filter: 5.6.31 -> 5.6.32 [pfSense]
    	php56-dom: 5.6.31 -> 5.6.32 [pfSense]
    	php56-curl: 5.6.31 -> 5.6.32 [pfSense]
    	php56-ctype: 5.6.31 -> 5.6.32 [pfSense]
    	php56-bz2: 5.6.31 -> 5.6.32 [pfSense]
    	php56-bcmath: 5.6.31 -> 5.6.32 [pfSense]
    	php56: 5.6.31 -> 5.6.32 [pfSense]
    	pfSense-rc: 2.4.0 -> 2.4.2 [pfSense-core]
    	pfSense-pkg-haproxy: 0.52_13 -> 0.54_2 [pfSense]
    	pfSense-pkg-acme: 0.1.19_1 -> 0.1.23 [pfSense]
    	pfSense-kernel-pfSense: 2.4.0 -> 2.4.2 [pfSense-core]
    	pfSense-default-config-serial: 2.4.0 -> 2.4.2 [pfSense-core]
    	pfSense-base: 2.4.0 -> 2.4.2 [pfSense-core]
    	pfSense-Status_Monitoring: 1.7.2 -> 1.7.5 [pfSense]
    	pfSense: 2.4.0 -> 2.4.2 [pfSense]
    	nginx: 1.12.1_1,2 -> 1.12.1_2,2 [pfSense]
    	mpd5: 5.8_2 -> 5.8_3 [pfSense]
    	lua53: 5.3.4 -> 5.3.4_1 [pfSense]
    	dpinger: 2.0_1 -> 3.0 [pfSense]
    	curl: 7.56.0 -> 7.56.1 [pfSense]
    
    Number of packages to be installed: 2
    Number of packages to be upgraded: 49
    
    The process will require 2 MiB more space.
    69 KiB to be downloaded.
    [1/51] Fetching pfSense-pkg-haproxy-0.54_2.txz: ......... done
    Checking integrity... done (0 conflicting)
    >>> Downloading pkg... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    
    pkg-1.10.1_1 is locked and may not be modified
    Failed
    
    


  • Came to say thanks!

    this happen to me since a bad update from 2.3.4 to 2.4.0.

    zero result on google despite to "force"  the update (that broke things worst since it updated to a beta!).

    THANKS again.



  • I think this also killed 2.4.1 dev to 2.4.2 upgrade path as well.


Log in to reply