How to enable speedstep in bios on minisys box



  • I’m working on configuring my new pfSense box and would like to use powerd, but for that to work I need to enable Intel SpeedStep. I’ve been through the bios several times. I don’t see any settings for speedstep in advanced>cpu. Am I looking in the wrong menu?


  • Netgate Administrator

    The BIOS may not provide a setting. Or it may not pass the required values via ACPI.

    The the boot log when you have powerd enabled, do you see any entries for est?

    Correctly detected and attached:

    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    est2: <enhanced speedstep="" frequency="" control=""> on cpu2
    est3: <enhanced speedstep="" frequency="" control=""> on cpu3</enhanced></enhanced></enhanced></enhanced>
    

    Not correctly attached:

    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est: cpu_vendor GenuineIntel, msr b280b2806000b28
    device_attach: est0 attach returned 6
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est: cpu_vendor GenuineIntel, msr b280b2806000b28
    device_attach: est1 attach returned 6</enhanced></enhanced>
    

    Steve



  • @stephenw10:

    Correctly detected and attached:

    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    est2: <enhanced speedstep="" frequency="" control=""> on cpu2
    est3: <enhanced speedstep="" frequency="" control=""> on cpu3</enhanced></enhanced></enhanced></enhanced>
    

    Not sure how to access the boot log but I think I did see this whiz by on the monitor during boot. I guess this means that speedstep is enabled by default. Thanks for the help.


  • Netgate Administrator

    It's in /var/log/dmesg.boot

    You can open that from Diagnostics > Edit File.

    Or you can run:

    cat /var/log/dmesg.boot
    

    Steve



  • Thanks.

    The retailer that I purchased the minisys box from claims that SpeedStep isn’t supported by the board they use. Pretty sure they are wrong though. I can see that CPU frequency is throttled in the dashboard. They also tried to tell me that the box uses Realtek nics. They’re really Intel.😏

    My guess is that SpeedStep is enabled but there isn’t a bios setting for it.



  • The E3845 CPU definitely supports EIST, so that should work indeed.


  • Netgate Administrator

    The board has to have the correct bit set for Speedstep to be enabled but it sounds like it is there whatever they say,  ::)

    If you see the CPU frequency scaling in the dashboard (in rational steps) that's usually fairly conclusive.

    You can also see the available levels from:

    [2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.est.0.freq_settings
    dev.est.0.freq_settings: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0
    
    [2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.cpu.0.freq_levels
    dev.cpu.0.freq_levels: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0
    
    

    Those should show the same levels otherwise it's using some other frequency scaling which is usually a bad thing.

    Steve



  • @stephenw10:

    The board has to have the correct bit set for Speedstep to be enabled but it sounds like it is there whatever they say,  ::)

    If you see the CPU frequency scaling in the dashboard (in rational steps) that's usually fairly conclusive.

    You can also see the available levels from:

    [2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.est.0.freq_settings
    dev.est.0.freq_settings: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0
    
    [2.4.2-RELEASE][admin@8860.stevew.lan]/root: sysctl dev.cpu.0.freq_levels
    dev.cpu.0.freq_levels: 2400/8 2200/0 2000/0 1800/0 1600/0 1400/0 1200/0
    
    

    Those should show the same levels otherwise it's using some other frequency scaling which is usually a bad thing.

    Steve

    Not sure what this means?

    Clip from boot log-

    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    est2: <enhanced speedstep="" frequency="" control=""> on cpu2
    est3: <enhanced speedstep="" frequency="" control=""> on cpu3</enhanced></enhanced></enhanced></enhanced>
    

    From ssh-

    [2.4.2-RELEASE][wgstarks@odin.dahoney.me]/root: sysctl dev.est.0.freq_settings
    dev.est.0.freq_settings: 1909/2000 1743/1835 1577/1670 1411/1505 1245/1341 1079/1176 913/1011 747/847 498/600
    [2.4.2-RELEASE][wgstarks@odin.dahoney.me]/root: sysctl dev.est.0.freq_levels
    sysctl: unknown oid 'dev.est.0.freq_levels'
    

    Dashboard screenshot-


  • Netgate Administrator

    Looks like you missed part of the difference between those lines. It should be:

    sysctl dev.cpu.0.freq_levels
    

    The output from the other sysctl looks good though. It lists valid Wattage numbers next to each step at least. The driver is ceratinly loading and attaching correctly.

    Steve


Log in to reply