Slow upload speed with Google Fiber [RESOLVED]

  • Hi guys, I'm hoping you can help me troubleshoot my slow upload speed on gFiber after bypassing the network box with pfSense.

    I have followed the guides and have VLAN tagging and QoS priority set to 2/3 respectively and I am getting about 935 down/100 up. I have confirmed with the network box attached instead of my pfSense box, I can obtain 930/930. Speeds were tested via both and and give similar results. Upload actually starts around 200-300, but then drops below 100 after a few seconds. CPU usage never goes above 1-2% and load avg is around 0.19, so it doesn't appear to be a bottleneck issue.

    My pfSense is updated to 2.4.2 and is running on a Lenovo TS140 (704A) server with an I3-4130 3.4GHz CPU, 8GB DDR3 ram, 250GB SSD, and an Intel PRO/1000 PT PCI-E dual NIC.

    Network setup: Fiber jack > pfSense > unmanaged D-Link gigabit switch > hosts

    Things I have tried:

    • Disabling Hardware Checksum Offloading

    • Disabling Hardware TCP Segmentation Offloading

    • Disabling IPv6

    Any suggestions you can offer would be greatly appreciated.

  • Is this pfsense box recycled from a previous connection type?  First thing that popped into my head when reading this is that traffic shaping or limiters are enabled on pfsense with an upload bandwidth set to 100Mbs.  Would probably explain the quick spike to 300 out of the gate then the shaper taking over and limiting upload to 100Mbps.

  • It is recycled from a Comcast Business Class connection of 75/20, but there have never been any traffic shaping rules in place. I just double checked and there is nothing there currently for sure. That was a good thought, though. I would have felt dumb (and happy) if that was the cause.

  • Uggh. Turns out it was a software issue on the Windows host I was using to test the speeds. Rogue "optimizer" software that came bundled with my motherboard drivers was causing the upload speed issues. I figured it out when I tested on a Linux box on the same LAN and the speeds were perfect. Hope this helps someone else down the road.

Log in to reply