Windows 10 and RDNSS

  • Supposidly Windows 10 supports RDNSS as of the Creators Update. In pfSense I've got my router mode set as Unmanaged and have entered my DNS servers at the bottom of that page. Windows still doesn't get them assigned. Have I got something setup wrong? Should I be using a different Router mode? Or does it just not work with Windows 10 yet?

    Thank you,

  • Because of Windows 10, I have usually run DHCPv6 on my main LAN, but have a second guest network that is set to Unmanaged (which is where my work Android device resides when I'm at home). Anyway, to test this, I connected my Win10 laptop (which is running the Fall Creators Update - build 1709) to my Guest network.

    I don't have any DNS servers specified, so pfSense should be simply specifying its own IP address instead, but my Win10 laptop does not appear to receive any IPv6 DNS servers when connected to my Guest network. However, I do specify a domain search list in the RA settings, and it does appear to be picking that up… not sure why it's not getting the server IP though.

  • Try this:

    Open an elevated cmd

    Type: "netsh interface ipv6 show interfaces" and hit enter.

    Make note of the "Idx" number it displays for your Ethernet adapter

    Type: "netsh int ipv6 set interface <idx>rabaseddnsconfig=enabled" (where <idx>is the number without <>) It should say "Ok." after you hit enter.

    Reboot Windows and it should have DNS information via RDNSS.

    I did the above and switched my pfSense RA to Unmanaged, before rebooting my Windows box, and it seemed to work for me.</idx></idx>

  • Thank you scott83. I've tested and that setting was already enabled on my computer. I ran the enable command again and rebooted and still no DNS via RA. I'm wondering if I've set something somewhere else in pfSense that is stopping it from sending the DNS via RA?

Log in to reply