Netgate_Coreboot_Upgrade issue with XG-2758



  • Tried to update 2 of 4 XG-2758 and it's not working.  >:(

    • The version is reverting to a lesser firmware version

    • The serial number in the console looks like this ▒▒▒▒▒▒▒▒▒▒  and in the GUI ����������

    Firmware update didn't work on one of my SG-4860's but I'm sure that was an INTEL ATOM core processor issue (unit was RMA'd).
    When I attempt to run the update again  I get this in the GUI:

    The following input errors were detected:
    Coreboot update failed.
    Netgate Coreboot update output
    Incorrect flash image file size.
    Failed to update OEM section, exiting …
    Updating flashing ...
    SN: �����������z����
    Serial Number Read from Flash �����������z����

    I would post the logs but I have a /24 & /23 subnets on the box (all ip addresses present) so it took up most of the log that I can view in the GUI.

    Needless to say I'm talking about production units here and I'm not to happy that both sites now have backups that I can't trust...

    How do I resolve this issue?

    Thanks for your help.


  • Rebel Alliance Developer Netgate

    Looks like this: https://redmine.pfsense.org/issues/8047

    But you may have to contact our support team for help fixing the serial number.



  • That link was INCREDIBLY helpful!!

    Halted the box, flipped the switch off, unplugged/plugged the unit, then turned the power back on.

    Problem was solved.


Log in to reply