Can't ping 'GUEST' interface on pfsense route.



  • Hello all,

    I've run into a wierd issue with my setup. I have a pfsense 2.4.2 setup on a Super Micro C2758. I have it configured to route most my LAN network through a VPN (newshosting.com) and all's working fine at that end.

    As the board has 2 spare nics, I decided to setup a 'guest' network connecting a AP to one of the spare ports. I like to take things step by step so I decided to first setup the new interface just like a standard LAN network -
        1. 'Assigned' a new network called GUEST to igb3 nic with static IP (192.168.25.1).
        2. TSetup DHCP using the console - 'Set interface(s) IP Address' option (for some reason the Web Configurator did not give me an option to configure DHCP on this new interface).

    I have not configured any rules etc on this new interface and I've also confirmed that neither 'Block private networks and loopback addresses' nor 'Block bogon networks' are set.

    Now here's the problem - when I connect a laptop directly to the 'GUEST' interface, the laptop get's a IP address on the 192.168.25.X network and the gateway is properly assigned (192.168.25.1).  But for some reason, I just can't ping the gateway address. When I connect the same laptop the 'LAN' interface, it pings just fine.

    I've tried re-booting the router and the laptop, but that did not help.

    Can someone please help me understand what I'm doing wrong  ??? - I think it's a very basic setup (other than the pfsense router being setup as a VPN client) which I hoped would work without much fuss. :-\

    Thanks in advance.
    Gurvinder


  • LAYER 8 Netgate

    1. 'Assigned' a new network called GUEST to igb3 nic with static IP (192.168.25.1).

    (for some reason the Web Configurator did not give me an option to configure DHCP on this new interface)

    Check the netmask on the interface itself. You probably want /24 there.



  • Thanks Derelict,

    That fixed the DHCP issue  :) - yes I can now configure DHCP using the WebConfigurator. But I still can't ping from a laptop connected to this interface / nic.


  • LAYER 8 Netgate

    I have not configured any rules etc on this new interface.

    If there are no rules, the interface will not accept any traffic. Not even ping.



  • Ok - just configured GUEST with a pass for Source:any/any Destination:any/any and gateway:any rule on the GUEST interface - still no dice.

    What should I check for next ?


  • LAYER 8 Netgate

    Post your rules. Be sure it isn't TCP-only.

    https://doc.pfsense.org/index.php/Connectivity_Troubleshooting


Log in to reply