Routing issue with AT&T?



  • So I switch from Spectrum to A&T.  I was fine with my SB6121->pfsense->LAN, but now that I have the BGW210-700->pfsense->LAN, I can't seem to get to the internet from anything behind pfsense.  I have IP Passthrough enabled on the BGW210, but still no internet.  I can ping 8.8.8.8 from pfsense, but no internet from the LAN.  I can update packages on pfsense as well.  I have changed the pfsense LAN to 192.168.2.x since the BGW210 is 192.168.1.x, but other than that, nothing else has changed.

    Yes, I have asked on the AT&T forum and have no luck.  I've tried their support and they want to pass me off to their paid "advanced" service since I can't seem to get on the internet.

    Any ideas?



  • Hi,

    Just reboot pfsense it should start working. This happens if your lan ip series becomes wan ip series…. i mean I did the same ... rebooting resolved the issue.

    cheers,
    Ashima



  • @ashima:

    Hi,

    Just reboot pfsense it should start working. This happens if your lan ip series becomes wan ip series…. i mean I did the same ... rebooting resolved the issue.

    cheers,
    Ashima

    I have already done that.  I have also verified both IPv4 and IPv6 is enabled on the WAN of pfsense.



  • @false:

    @ashima:

    Hi,

    Just reboot pfsense it should start working. This happens if your lan ip series becomes wan ip series…. i mean I did the same ... rebooting resolved the issue.

    cheers,
    Ashima

    I have already done that.  I have also verified both IPv4 and IPv6 is enabled on the WAN of pfsense.

    I am running into the same issue. Granted, I have multiple VLANs in play, a couple of days ago, one of my VLANs (The one that I use for management) stopped connecting to the internet. For awhile, the VLAN that I use for clear traffic (pretend this is my LAN) worked, but while trying to see what this issue is, I rebooted my APU and suddenly, the VLAN no longer connected to the internet. Like you, I also am trying to use IP Passthru, but my WAN interface is still showing at the 172.16.0.0 network that I have the DSL modem set to, and the only way that I can access the internet is through using the wifi interface on the BGW-210 modem.

    Any other suggestions?



  • @false:

    So I switch from Spectrum to A&T.  I was fine with my SB6121->pfsense->LAN, but now that I have the BGW210-700->pfsense->LAN, I can't seem to get to the internet from anything behind pfsense.  I have IP Passthrough enabled on the BGW210, but still no internet.  I can ping 8.8.8.8 from pfsense, but no internet from the LAN.  I can update packages on pfsense as well.  I have changed the pfsense LAN to 192.168.2.x since the BGW210 is 192.168.1.x, but other than that, nothing else has changed.

    If you have an ip passthrough, is your Wan interface on pfsense getting a public ip?

    There is something more to it that’s missing. Could be something with routing/gateway or rules but cannot say anything without looking at it



  • @GoldFish:

    @false:

    So I switch from Spectrum to A&T.  I was fine with my SB6121->pfsense->LAN, but now that I have the BGW210-700->pfsense->LAN, I can't seem to get to the internet from anything behind pfsense.  I have IP Passthrough enabled on the BGW210, but still no internet.  I can ping 8.8.8.8 from pfsense, but no internet from the LAN.  I can update packages on pfsense as well.  I have changed the pfsense LAN to 192.168.2.x since the BGW210 is 192.168.1.x, but other than that, nothing else has changed.

    If you have an ip passthrough, is your Wan interface on pfsense getting a public ip?

    There is something more to it that’s missing. Could be something with routing/gateway or rules but cannot say anything without looking at it

    I noticed that my WAN interface was still showing the 172.16.0.0/24 network as opposed the public address. It is interesting to me that initially, one VLAN stopped connecting to the internet, but the other VLAN was working fine. After my reboot, both VLAN failed to connect to the internet. I truly wished that I didn't have to use AT&T as a provider!



  • @kcallis:

    I noticed that my WAN interface was still showing the 172.16.0.0/24 network as opposed the public address.

    I would look at the rules. Personally not a big fan of double nat



  • @GoldFish:

    @kcallis:

    I noticed that my WAN interface was still showing the 172.16.0.0/24 network as opposed the public address.

    I would look at the rules. Personally not a big fan of double nat

    Thank for suggesting to look at my rules. Of course, the issue wasn't my rules, but the search mode of looking for everything caused me to look for other things that were out of whack. I was looking at the Dashboard and noticed that I was seeing on top of the normal DNS servers, I was also seeing 127.0.0.1 (localhost). I took at look at System/General Setup and realized that I had not checked the Disable DNS Forwarder. One check of a box, and lo and behold packets were resolving and running out into the wild frontier of the internet.

    Another nice thing was that finally I was able to get the IP Passthrough working and now my WAN interface now shows the public IP address. Life is groovy!


Log in to reply