[SOLVED] Update error on 2.4.1



  • Hi all! I'm new to pfSense and set up my router with version 2.4.1 a few weeks ago. I went to update last week and was met with this error:

    
    Crash report begins.  Anonymous machine information:
    
    amd64
    11.1-RELEASE-p4
    FreeBSD 11.1-RELEASE-p4 #5 r313908+79c92265a31(RELENG_2_4): Mon Nov 20 08:18:22 CST 2017     root@buildbot2.netgate.com:/builder/ce-242/tmp/obj/builder/ce-242/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [03-Dec-2017 03:55:24 Etc/UTC] PHP Fatal error:  Call to undefined function update_repos() in /usr/local/www/pkg_mgr_install.php on line 368
    
    No FreeBSD crash data found.
    
    

    I ssh'ed in and ran option 13 which reported all repos were up to date. I know version 2.4.2 should be out so I'm not sure how to fix. This. Thanks in advance!



  • This was originally posted for users having issues updating from 2.3.*, but I think it should also work for you, try it and see.

    https://forum.pfsense.org/index.php?topic=140308.msg766562#msg766562



  • Thank you for the tip, but my system is still reporting up to date.

    
    [2.4.1-RELEASE][admin@pfSense.localdomain]/root: pkg update -f
    Updating pfSense-core repository catalogue...
    Fetching meta.txz: 100%    944 B   0.9kB/s    00:01    
    Fetching packagesite.txz: 100%    2 KiB   1.7kB/s    00:01    
    Processing entries: 100%
    pfSense-core repository update completed. 7 packages processed.
    Updating pfSense repository catalogue...
    Fetching meta.txz: 100%    944 B   0.9kB/s    00:01    
    Fetching packagesite.txz: 100%  130 KiB 133.5kB/s    00:01    
    Processing entries: 100%
    pfSense repository update completed. 491 packages processed.
    All repositories are up to date.
    
    


  • Looking at the source code I've noticed that update_repos was not added until version 2.4.2 so it looks like my system did a partial upgrade. I manually copied over /etc/inc/pkg-utils.inc from https://github.com/pfsense/pfsense/blob/master/src/etc/inc/pkg-utils.inc and the web UI now reports all packages are up to date but the current version is still showing as 2.4.1.

    Is there a way to reinstall all packages?



  • OK I think I've resolved the issue by forcing a reinstall of all the pfsense packages.

    While ssh'd in to the box and in a shell, I ran pkg info | less to look at the names of all installed packages.

    I ran pkg clean -ay to clean the archives.

    I ran the following to force a reinstall of all.

    
    pkg install -fy pfSense-2.4.2 pfSense-Status_Monitoring-1.7.5 pfSense-base-2.4.2 pfSense-default-config-2.4.2 pfSense-kernel-pfSense-2.4.2 pfSense-rc-2.4.2 pfSense-repo-2.4.2_1 pfSense-upgrade-0.40
    
    

    And now the web UI reports

    
    2.4.2-RELEASE (amd64)
    built on Mon Nov 20 08:12:56 CST 2017
    FreeBSD 11.1-RELEASE-p4
    
    

Log in to reply