Solved: Bizarre NIC problem



  • This is probably more a freebsd problem but may be somebody can give me a hint

    I want to setup a 2.4.2 test system with an old Lenovo M52. It has a "Broadcom NetXtrem GBit" network card which is recognized from pfsense and also gets an IP Adress as the "WAN" side. If it is the only network card in the system.

    When I insert a second network card (NatSemi DP8381) it also gets recognized.

    But: as soon as I insert the second card without touching the network cable the internal Broadcom card stops working. The cable is there but ifconfig reports "media Ethernet none"

    Any Ideas?



  • If you reboot with the second NIC inserted, does ifconfig show the Broadcom anymore?

    If not, maybe check your BIOS for something about the builtin NIC being disabled if a second one is connected. Check the BIOS updates too while you're at it in case this is mentioned.

    Just an idea. Seems like a long shot but you never know.



  • unfortunately reboot does not help and ifconfig does show both cards.

    The bios does not have much settings and I already tried various setting without any luck



  • Maybe address/IRQ problem? It's a bit oldschool but it's pretty weird.


  • Banned

    On some old systems the integrated NIC will be disabled by the BIOS as soon as an additional NIC is inserted. So get a Intel NIC with two ports and just forget the integrated one.



  • This might help you figure out more info.

    Run the command 'dmesg' before inserting the second card and after. Share the new stuff that's added to dmesg when inserting the second card.

    The system logs may also have some information.

    Otherwise, Grimson is probably right.



  • @darkcrucible:

    Run the command 'dmesg' before inserting the second card and after. Share the new stuff that's added to dmesg when inserting the second card.

    I am not inserting the card while the system is powered on. So I cant provide this.

    @darkcrucible:

    Otherwise, Grimson is probably right.

    Thats what I wanted to find out and

    The card is working fine with Debian 9

    Then I reinstalled pfsense withouth touching anything on the hardware and then i have a pfsense box that is recognizing the card but believes there is no cable is connected.

    So I believe we can exclude bios / hardware issues.



  • there are some new findings

    After the card was working with Debian I thought I give a vanilla FreeBSD install a try.

    At first the results where the same as with pfSense installation.

    After 10 Pages of Google result I fount this https://forums.freebsd.org/threads/5457/ and I gave the recommendation a try

    
    # ifconfig -m bge0
       ......
       supported media:
       media 10baseT/UTP
       media none
    #ifconfig bge0 media 10baseT/UTP
    #ifconfig bge0
    
    

    tataaa. The card now knows the cable is there and I get an IP address

    Is there any way I can automate this in the pfSense boot up phase?



  • @hbauer:

    there are some new findings

    After the card was working with Debian I thought I give a vanilla FreeBSD install a try.

    At first the results where the same as with pfSense installation.

    After 10 Pages of Google result I fount this https://forums.freebsd.org/threads/5457/ and I gave the recommendation a try

    
    # ifconfig -m bge0
       ......
       supported media:
       media 10baseT/UTP
       media none
    #ifconfig bge0 media 10baseT/UTP
    #ifconfig bge0
    
    

    tataaa. The card now knows the cable is there and I get an IP address

    Is there any way I can automate this in the pfSense boot up phase?

    There's a package called ShellCmd which I believe can do what you're looking for.



  • much easier. I reinstalled pfsense and started the ifconfig command ones to get started and configure pfsense.

    Then I went back to the WAN setting and if found this setting " Speed and Duplex" where I could set the necessary media type.

    Rebooted and the WAN address got the ip address ;-)

    Everything looks good


Log in to reply