2.4.2 TO 2.4.2_1 ERROR: pkg-1.10.1_1 is locked and may not be modified Failed



  • pkg-1.10.1_1 is locked and may not be modified
    Failed

    Can't seem to update and this is what I get. (Terminal and browser)

    Thoughts anyone?



  • Unable to reproduce. Here is my log.

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Downloading upgrade packages...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (6 candidates): ...... done
    Processing candidates (6 candidates): ...... done
    The following 6 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pfSense-rc: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-kernel-pfSense: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-default-config: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-base: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense: 2.4.2 -> 2.4.2_1 [pfSense]
    curl: 7.56.1 -> 7.57.0 [pfSense]

    Number of packages to be upgraded: 6

    53 MiB to be downloaded.
    [1/6] Fetching pfSense-rc-2.4.2_1.txz: .. done
    [2/6] Fetching pfSense-kernel-pfSense-2.4.2_1.txz: …....... done
    [3/6] Fetching pfSense-default-config-2.4.2_1.txz: . done
    [4/6] Fetching pfSense-base-2.4.2_1.txz: …....... done
    [5/6] Fetching pfSense-2.4.2_1.txz: . done
    [6/6] Fetching curl-7.57.0.txz: …....... done
    Checking integrity... done (0 conflicting)

    Upgrading pfSense kernel...
    Checking integrity... done (0 conflicting)
    The following 2 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pfSense-kernel-pfSense: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-rc: 2.4.2 -> 2.4.2_1 [pfSense-core]

    Number of packages to be upgraded: 2
    [1/2] Upgrading pfSense-rc from 2.4.2 to 2.4.2_1…
    [1/2] Extracting pfSense-rc-2.4.2_1: …. done
    [2/2] Upgrading pfSense-kernel-pfSense from 2.4.2 to 2.4.2_1…
    [2/2] Extracting pfSense-kernel-pfSense-2.4.2_1: …....... done
    ===> Keeping a copy of current kernel in /boot/kernel.old
    Upgrade is complete.  Rebooting in 10 seconds.
    Success



  • It shows similar.  get to the packages to be upgraded. I get the to be downloaded. I get the fetching. I get the checking integrity… done (0 conflicting).

    I get to most of what you are saying and it says it is  >>> downloading pkg...

    updating...
    ...is upt to date
    updating...
    ...is up to date

    All repositories are up to date.

    obviously I'm abbreviating but should be easy to follow.

    It indicates the only update to download was the pfSense stuff and a curl item. I just can't seem to get it to  install and I get the

    pkg-1.10.1_1 is locked and may not be modified
    Failed

    when I try to in browser etc.

    In browser:

    Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Downloading upgrade packages...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (6 candidates): ...... done
    Processing candidates (6 candidates): ...... done
    Checking integrity... done (0 conflicting)
    The following 6 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pfSense-rc: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-kernel-pfSense: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-default-config: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense-base: 2.4.2 -> 2.4.2_1 [pfSense-core]
    pfSense: 2.4.2 -> 2.4.2_1 [pfSense]
    curl: 7.56.1 -> 7.57.0 [pfSense]

    Number of packages to be upgraded: 6

    Downloading pkg…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    pkg-1.10.1_1 is locked and may not be modified
    Failed



  • Seems to be good now. Perhaps the lock was something temporary. I dunno. I upgraded. Thanks.