Arris TM1602 Cable Modem -> Netgate SG-1000 WAN = No IP



  • Hello,

    It's been awhile since I've worked with pfsense. I typically work with WatchGuard/CISCO products. Anyways, I'm having a major problem here for a personal client of mine who just purchased the Netgate SG-1000 awhile back. Fortunately the client and I have the same cable modem so I brought the Netgate home with me.

    The same problem exists on both his modem and mine, tested and verified.

    All settings are default for the Netgate SG-1000 and I have factory reset the device many times to no avail. I have tried manually entering a MAC to no availability.

    When the Arris modem is plugged directly into the WAN port on a router everything works just as intended - there is no need to modify anything(not that you can) in the Arris modem. The ISP(Charter) distributes IPs dynamically.

    When I power cycle the Arris modem, the modem comes back online and indicates "Online" with a solid blue light. I power on the Netgate. I wait 5-10 minutes and verify the Netgate is on by logging into it's default gateway, 192.168.1.1

    The WAN light does not come on. There is no activity. I am able to access the gateway and modify configurations.

    Now, if I take the patch coord from Modem -> Netgate WAN and swap it over to Router(with DHCP) -> Netgate WAN the WAN port becomes active, lights come on and it receives an IP addres.

    This problem has been verified on two separate Arris TM1602 modems. I've attached some screen shots of my configuration and for the life of me I cannot figure out why this device is not receiving a IP address from the Arris modem. The Arris modem gives routers a perfectly fine IP, the modem gives my laptop an IP perfectly fine - but it will NOT give the Netgate SG-1000(pfsense ARM box) an IP.

    Your help is greatly appreciated.

    http://image.ibb.co/caaM0R/status.jpg
    http://image.ibb.co/cgmiEm/1.jpg
    http://image.ibb.co/mrvzn6/2.jpg
    http://image.ibb.co/gNcZLR/3.jpg



  • Try to set "Speed and Duplex" to a fixed value instead of Auto-negotiate.
    Also uncheck "Block private networks" on your WAN interface if you get an RFC1918 IP from your modem.



  • Please remove this thread I discovered the problem.

    Always check your physical layer folks. Ended up being the cable I had from another jobsite - it only had 4 strands of copper….



  • ;D    None of us have ever been fooled by that one..    Not!

    By the way-  Regarding your modem check-  http://badmodems.com/Forum/app.php/badmodems



  • it only had 4 strands of copper….

    Which 4 strands?  10 & 100 Mb only require 2 pairs, on pins 1, 2, 3 & 6.  Of course, they have to be proper twisted pairs, not the no pair silver satin stuff.



  • @tech29312:

    … the cable ... only had 4 strands of copper...

    Well, if those are not unusally connected then it should be good for 100Mb FD, shouldn't it?



  • What ?
    Do we need more then 4 coppers between 2 NIC's ? Shouldn't I use those phone wires ?l
    ;D