PPP interface not working after reboot



  • I've got a 3g usb modem working in pfsense, however after a reboot the interface doesn't come back online. If I go into Interfaces -> PPPs, edit and save the config without making any actual changes, the interface comes back online right away.

    I've also noticed that in /var/etc prior to reboot there is a 'mpd_opt1.conf' and a symlink for 'mpd.script -> /usr/local/sbin/mpd.script', these are missing after a reboot.

    I had /var and /tmp in a ramdisk, disabling this doesn't fix the problem. I've also tried setting dial on demand as well to no avail. The interface is simply not attempted to be brought online by pfsense until I manually go into the gui and re-save the config under PPPs. If I clear the ppp.log and reboot, the file remains empty.

    Is there a command I can run from the cli or such to do this same procedure without having to log into the web gui so I could at least script a work around? I've tried copying the files back into /var/etc after a reboot but I've found no way to kick mpd by hand to get it to reinitialize the interface.

    EDIT: I found a workaround here: https://forum.pfsense.org/index.php?topic=125499.msg769167#msg769167

    I installed a shellcmd

    php -r 'require_once("shaper.inc"); require_once("filter.inc"); interface_ppps_configure('opt2');'

    to fix this issue.

    Replace opt2 with the optx you are using.