Upgraded to 2.4.2_1 But still shows 2.4.2



  • Upgraded to 2.4.2_1 but shows old version.

    2.4.2-RELEASE (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6

    Version 2.4.2_1 is available.
    Version information updated at Sun Dec 17 13:25:01 EST 2017

    But when I go to upgrade it I get this;

    Current Base System 2.4.2_1
    Latest Base System 2.4.2_1
    StatusUp to date.

    And I've rebooted it a couple of times. No Change.


  • Rebel Alliance

    I assume your settings are on the "Stable Release".
    Was it previously on "Development"?
    I had a similar issue a with v2.3.5.



  • Yes. I only run the Stable Versions.  I've seen this issue before maybe they'll put a fix out for it.


  • Rebel Alliance Developer Netgate

    What does the output of "pkg info -x pfsense" show?



  • pfSense-2.4.2
    pfSense-Status_Monitoring-1.7.5
    pfSense-base-2.4.2_1
    pfSense-default-config-2.4.2_1
    pfSense-kernel-pfSense-2.4.2_1
    pfSense-pkg-apcupsd-0.3.9_3
    pfSense-pkg-nmap-1.4.4_1
    pfSense-pkg-nut-2.7.4_5
    pfSense-pkg-openvpn-client-export-1.4.14
    pfSense-pkg-pfBlockerNG-2.1.2_2
    pfSense-rc-2.4.2_1
    pfSense-repo-2.4.2_1
    pfSense-upgrade-0.40
    php56-pfSense-module-0.57


  • Rebel Alliance Developer Netgate

    Looks like some parts of the OS did not get updated. Try running "pfSense-upgrade -d" from the command line (ssh or console) and see if that helps.

    For example, a 2.4.2-p1 box should have pfSense-2.4.2_1 and yours does not.



  • That fixed it!

    Thank You.



  • Hey guys, I'm having a similar issue with trying to upgrade from 2.3.4 to 2.3.5.  I tried the suggestion of  running "pfSense-upgrade -d" from the command line (ssh or console), and something happened and it rebooted, but I'm still on 2.3.4.

    Any more ideas?

    I've been having many issues with updates. We have 5 installations using pfSense and often the only way to help them realise that they have an update available is to go to System -> Update -> Update Settings and change it from "stable" to another option, save it, then change it back to stable again, then go back to System Update and hopefully it realises it has an update available.  This has worked a few times, but with this last one, it has not worked.

    Why such a problematic update system?



  • I am having a similar issue going from 2.4.1 to 2.4.2_1

    pkg info -x pfsense Shows:

    pfSense-2.4.1
    pfSense-Status_Monitoring-1.7.3
    pfSense-base-2.4.1
    pfSense-default-config-2.4.1
    pfSense-kernel-pfSense-2.4.2_1
    pfSense-pkg-Cron-0.3.7_2
    pfSense-pkg-Status_Traffic_Totals-1.2.1_2
    pfSense-pkg-System_Patches-1.1.7
    pfSense-pkg-bandwidthd-0.7.4_1
    pfSense-pkg-squid-0.4.42
    pfSense-rc-2.4.2_1
    pfSense-repo-2.4.2_1
    pfSense-upgrade-0.40
    php56-pfSense-module-0.54
    

    and running "pfSense-upgrade -d" did not solve the problem.

    also noticed that if i changed from "latest stable version (2.4.x)" to "latest development snapshot (2.4.x DEVEL)" it said that i was up to date.

    any ideas?



  • Anyone?



  • I am having a similar issue.  I did an upgrade from 2.3 via service console

    dashboard states:
    2.4.2-RELEASE (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6

    Widget Netgate services and support continues to spin stating "Retrieving support information"

    I also tried pfSense-upgrade -d, and it stalls at " Updating repositories metadata.

    Now, I think I broke it by deleting some *.conf file on the initial upgrade as the installed recommended removing it.  I do not remember what it was.

    So on the assumption I 'bricked' it, how can I reimage it?  It was purchased from Netgate ( Netgate SG-4860)
    Netgate device ID: 67f61d3cb8fa0b145112

    Found reference in manual to got netgate portal (I have gold membership) to DL the image.  I cannot find a link for downloading an image.

    The pfSense site has a select for Netgate ADI under architecture, but I don't know if this is it or not.

    Thanks for any help!

    Thanks



  • Success!

    After quite a bit of Googling, I was able to find the solution.

    I now have a fully functional SG-4860 again!

    Once I was able to put the pieces together, the process was simple and painless.



  • Does anyone have a solution for when it won't update either from the Web gui or the command line?


  • Rebel Alliance

    Save your config, then reinstall 2.4.2-1 from scratch, then upload old config



  • This is a good solution, except its difficult to do remotely.

    Any other ideas?



  • @pr4499:

    This is a good solution, except its difficult to do remotely.

    Any other ideas?

    Ship a prepared unit to the site, and have the installed one shipped back ?



  • Again, this would require the end user to know what to do with it.

    Does anyone know the actual cause of this issue? And a command to fix it?



  • different version numbers, same issue. Anyone got an idea about this one?

    Today's output from the command "pfSense-upgrade -d" is:

    >>> Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Network is unreachable
    repository pfSense-core has no meta file, using default settings
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: Network is unreachable
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/meta.txz: Network is unreachable
    repository pfSense has no meta file, using default settings
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/packagesite.txz: Network is unreachable
    Unable to update repository pfSense
    Error updating repositories!
    

    output from "pkg info -x pfsense" is:

    pfSense-2.4.4
    pfSense-Status_Monitoring-1.7.6
    pfSense-base-2.4.4
    pfSense-default-config-2.4.4
    pfSense-kernel-pfSense-2.4.4
    pfSense-pkg-ntopng-0.8.13_3
    pfSense-rc-2.4.4
    pfSense-repo-2.4.4
    pfSense-upgrade-0.59
    php72-pfSense-module-0.64_6
    

    It appears it can't get out to the internet:

    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: No route to host
    ping: sendto: No route to host
    ping: sendto: No route to host
    

    Which is strange because the connection is definitely up. We have a gateway group with 2 WAN connections. One is down, the other is up at the moment.



  • anyone?


  • LAYER 8 Rebel Alliance