One WAN goes down immediately on connecting

  • Not sure at this point if I have a hardware or generic pfsense issue but feel free to move this thread if required.

    This is giving me a real headache - I have a pfsense box that's been chugging away happily with 3 x WAN connections and 1 x LAN on 4 different NICs. The system is 2.3.3.

    One of the WANs (WAN3 on em2) went down last week so I called the ISP who said the line was fine.
    So I replaced the modem (it's DSL). The WAN came up for 1 second then went down again.
    So it can only be the pfsense, right?  Ordered a new NIC to replace. Whilst I was waiting, I cranked up an old pfsense box, connected WAN3 to it and WAN3 worked absolutely fine - I even upgraded the old pfsense to 2.4. So the issue must be with the live pfsense.  On this old box, both old and new modems work fine with this DSL connection.

    New NIC just arrived, so I put that in. Same thing is happening - WAN3 comes up and immediatley dies.  For info, this is the original WAN ie. the interface that can't be deleted.

    So, I even created a new PPP interface, and attached em2 to that. Still WAN3 goes straight down so not a corrupt interface.

    I changed the settings in System/Routing/Gateways/Edit/WAN3 and made all the latency 10x what they currently are to experiment. It didn't change the symptoms other than it takes a few seconds to go down now.

    I don't want to risk an upgrade to 2.4 on this live box just yet before xmas - it's in the pipeline - but I don't see how this would help in any case as it has been working fine on this version for months.

    So I seem to have ruled out hardware, the DSL and modem, the interface and the gateway parameters.  Nothing in the logs tells me a thing that looks helpful.

    There's something in the pfsense config that I can't get to the bottom of - any advice gratefully received!

  • Just a follow up as I haven't got this working yet.
    On the new pfsense box I fired up, it connects on the interface fine, and can install packages and update itself….... but the gateway is permanently down. It picks up a gateway/monitoring IP from the ISP, but just won't connect the gateway - 100% loss  and I am at a total loss as to whether it's the pfsense or the ISP. Help!

  • Hi,

    Is this a case where the gateway doesn't reply to pings ? This can happen.
    Chose another 'monitoring' IP to see if changes something.

  • Definitely looks like something in the live environment…

    So it’s a case of working through it...

    It’s not something stupid like a cable?

    Can you swap the physical interfaces over?  Swap the dsl box onto em1 and adjust the PPPoE assignments for example?

    What happens if you export the config to the old box you tested on?  Also what happens when you put a config backup onto the live box?

    If you are planning to go to 2.4 then maybe a fresh setup would be worth looking at instead of an upgrade?

  • @Gertjan:


    Is this a case where the gateway doesn't reply to pings ? This can happen.
    Chose another 'monitoring' IP to see if changes something.

    It was this - more details:

    I had tried as the monitor which also failed.  However choosing one of the ISPs DNS server as the monitor seems to have fixed it.

    Thanks for the suggestions from both.

  • @robatwork:

    I had tried as the monitor which also failed.  ….

    As far as I know, "" has been set up to reply to ping.
    But this "" can be far away for you - just count the 'hops' (actually : a router).
    You should know that every 'hop' has the right to throw away traffic that it thinks is "useless" because, example, its overloaded. And guess what : ICMP is just the protocol that gets thrown away if needed.
    A gateway monitor IP should as close as possible - often this is a device from your ISP.

Log in to reply