2.0 Build inv.



  • Hi.

    Do there exitst a how-to for setting up a build inv. for the version 2.0?

    For version 1.2 there was a very good guide for this, but i cant make it work on FreeBSD 7.0

    Best regards





  • I followed the instruction in sullrich post, launch cvsup_current. It compiles and install ports and tools without errors, just a few warnings on some ports. configure kernel finishes but build kernel stage sits idle for hours. It does not give any error, just sits there. launching another console and doing top I do not see any make or cc activity as I saw when building ports and tools.
    I am not sure what is going on. How can I enable more verbose reporting from the kernel buid script and see if any error has occurred? Is there a log I can tail?
    I am running FreeBsd 7.1 rc2 on vmware.
    I would really like to be able to compile a dev cd and start playing with it.

    Thanks

    Johnny



  • @sullrich:

    Try this http://devwiki.pfsense.org/DevelopersBootStrapAndDevIso

    Hello,

    I am running BSD 7.1. I am on a mission to compile the kernel with the elusive mrouting option enabled. Well after hours of browsing kernel configs and build scripts, I see the edit needs to be made in the files within /home/pfsense/tools/builder_scripts/config/ folder. Also, it looks like the BSD v7 kernel has the mrouting option already there.

    I followed the directions on the wiki and had no issues other than a few php version updates from cvs. I get an iso when I run build_iso.sh. The only issue I have is when booting with the cd made. I understand that one of the last steps is to compress the usr folder among others (i think).

    During boot, the kernel loads, but once past the initial load and it starts to load the cd as a file system, I get a ton of errors about files not found from the var and usr folders. It seems as though they are not being decompressed initially and the usr folder is empty on the cd.

    While troubleshooting, I made an iso using the /usr/local/pfsense-fs folder instead of the cloned folder since the pfsense-fs folder has the usr files there. Of course I get errors about the files/file system not being writable, but I can get to the menu loader and start a shell with that image. Mrouted command works. So the kernel is right, but I really need help with why the usr files do not decompress when booting the cd made from the pfsense-clone folder. I also have commented out the cvs from updating and changing my kernel mods in build_iso.sh (to troubleshoot also). Any ideas where to look?

    Thanks.



  • any chance of getting a dev iso for download?



  • @sai:

    any chance of getting a dev iso for download?

    Yeah, I'll get one posted today.



  • thanks. pls post url.



  • I've tried to follow http://devwiki.pfsense.org/DevelopersBootStrapAndDevIso but the process ends at the last line:
    ./cvsup_current
    which gives me "something went wrong while attempting installation of git."

    I commented out the git section in cvsup_current



  • So is there not just an ISO that I can boot from and either install, or use as a LiveCD, the FreeBSD version and development tools needed to create pfSense binaries/programs/mods??

    I'm a FreeBSD noob, but due have experience with Linux (Mostly RedHat in flavor) and although I might find it somewhat fun to try to set this up myself, I don't really have the time so anything that can help me save time would be great!

    Thanks!



  • try this : http://ftp.nhlue.edu.tw/pfsense/downloads/pfSense-Developers-1.2.2.iso.gz or whatever developer iso is available when you get to the mirrors.


Locked