High CPU Utilization After Upgrade 2.4-RC to 2.4.2-p1



  • Wondering if anyone else has seen this behaviour…

    Yesterday, I upgraded an SG-1000 from 2.4-RC to 2.4.2-p1.  Ever since then I've been noticing high CPU utilization.  I have posted a graph (last 48 hours) from one of my monitoring systems that shows the increase in CPU activity.

    Not 100% sure, but System Activity seems to show php-fpm at the top of the list.

    Anyone else seeing this?  Any thoughts?  I have restarted PHP-FPM as well as restarted the actual firewall itself, but it always comes back with this high CPU.

    Thanks,

    Dave
    ![Screen Shot 2017-12-20 at 09.16.54 AM.png](/public/imported_attachments/1/Screen Shot 2017-12-20 at 09.16.54 AM.png)
    ![Screen Shot 2017-12-20 at 09.16.54 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-12-20 at 09.16.54 AM.png_thumb)
    ![Screen Shot 2017-12-20 at 09.17.49 AM.png](/public/imported_attachments/1/Screen Shot 2017-12-20 at 09.17.49 AM.png)
    ![Screen Shot 2017-12-20 at 09.17.49 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-12-20 at 09.17.49 AM.png_thumb)


  • Rebel Alliance Developer Netgate

    That particular output doesn't show much. A few percent used by PHP, most likely because you're viewing that from the GUI.

    Connect to the console or ssh, start a shell and run "top -aSH" and wait a bit and see what shows up there.



  • Looks like my issue was being logged into the web portal.  When I logged out of the web portal, my CPU utilization went down to average around 10%.


  • Rebel Alliance Developer Netgate

    That is probably due to a netstat bug that was addressed a week or so ago. It will be better in 2.4.3, you can try a snapshot now if you like.



  • With pfSense 2.4.2-p1 on a Watchguard XTM 525 with celeron e3400 @ 2.6GHz i'm seeing 99% cpu usage after a few days. I've had to reboot a few times these last few weeks since the release. Is there anything I can provide to help identify this issue?



  • Looks like I may have found the issue. Under System > Advanced > Miscellaneous > RAM Disk Settings - I unchecked the "Use memory filesystem for /tmp and /var" and the issue seems to have gone away, with the CPU idling around 17% - but only time will tell.


Log in to reply