WARNING: Current pkg repository has a new OS major version.



  • I just upgraded to 2.4.2_1. Post upgrade when I go to install a package I get the following error:

    WARNING: Current pkg repository has a new OS major version. pfSense should be upgraded before doing any other operation

    Since I'm already on the latest major version I'm not sure why I'm getting this or how to work around it?

    Thanks
    Brad



  • Does it say :

    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6

    ?



  • @Gertjan:

    Does it say :

    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6

    ?

    Nope:
    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 10.3-RELEASE-p19

    So how do I upgrade from FreeBSD 10.3 to 11.1? Shouldn't PFSense do this for me when I check for updates?



  • @bab5470:

    @Gertjan:

    Does it say :

    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6

    ?

    Nope:
    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 10.3-RELEASE-p19

    So how do I upgrade from FreeBSD 10.3 to 11.1? Shouldn't PFSense do this for me when I check for updates?

    Looks like this from the shell will do the trick: pfSense-upgrade -d

    I'm now on 11.1 and I can install packages again!

    Thanks!!