WAN 0.0.0.0(DHCP)



  • Since january '08 i'm using pfsense on a old Dell p3. This week i tried to install pfsense on HP P4 (with 3 giga bit nics) but it did't worked as before.

    After the installation i see the following:
    LAN*  -> bge0  ->
    WAN* -> em0  -> 0.0.0.0(DHCP)
    OPT*  -> em1  -> NONE

    On the Dell it looked for the WAN as follows:
    WAN* -> dc0 -> 83.86.237.24(DHCP)

    What goes wrong and how can i fix it?

    Thanks



  • It looks as if your WAN interface hasn't been assigned an IP address by DHCP. I've read of Internet services fixed to a particular MAC address (cable modems if I recall correctly). If you want to change the MAC address of the interface of the interface connected to the internet (and in your case you apparently have because you've changed from a 'dc' to an 'em') you have to do something to reset the stored MAC address in the internet interface. If I recall correctly, in some cases it can be done by powering off the cable modem for a few minutes.

    If its possible, you might try the old WAN interface in the new system to see if that makes a difference. (In most cases a 10/100 WAN interface will be more than fast enough.)



  • Hello,

    Indeed, my cable company also "locks" MAC address when to provide me an address via dhcp. You should definitely check your ISP if they do something with your MAC address and/or follow a suggestion wallabybob kindly mentioned.

    cheers,



  • Hook it back up the way you had it before pfsense.  Establish Internet connection.  Release the IP.  Then hook back up pfsense and it should pull down the IP from your ISP DHCP server.



  • With my cable provider it can take several hours to update changes and the connection becomes active again, just leave it connected and switched on overnight.
    If its the mac address causing the problem you can enter the old mac on the WAN interface of pfsense box.


Locked