[RESOLVIDO] - Regras do NAT - Não consigo



  • Boa tarde pessoal,
    Tenho um problema nas regras do NAT, que to batendo a cabeça e não consigo resolver, vamos lá se vcs podem me ajudar.
    Tenho um servidor PFSense que roteia a internet na minha empresa. Ok
    Servidor PFSENSE:
    IP Valido: 200.103.100.25
    IP Interno: 10.0.0.1

    Tenho um outro servidor separado rodando Windows server, que tem uma aplicação WEB rodando na porta 3568.
    IP Interno: 10.0.0.2
    Para acessar internamente uso: http://10.0.0.2:3568/actWeb

    Eu fiz uma regra, para acessar o NAT externo, que quando alguém conectar pelo navegador pelo endereço http://200.103.100.25:3568 ele redireciona para o 10.0.0.2:3568, até aí tudo certo!!

    Só que se eu usar internamente (nos computadores da empresa) tentar acessar o link http://200.103.100.25:3568 ele não acessa, somente de fora.

    Resumindo:
    Fora da empresa:
    http://200.103.100.25:3568/actWeb: ACESSA

    Dentro da Empresa
    http://10.0.0.2:3568/actWeb: ACESSA
    http://200.103.100.25:3568/actWeb: NÃO ACESSA

    Alguém pode me ajudar por favor…. tá um caos aqui!



  • cara seguinte, isso de não abrir e comum imagina você entra ao mesmo tempo que sai !!! quanto a isso só seria possível se você utilizar um outro link ..



  • @overflow:

    Boa tarde pessoal,
    Tenho um problema nas regras do NAT, que to batendo a cabeça e não consigo resolver, vamos lá se vcs podem me ajudar.
    Tenho um servidor PFSense que roteia a internet na minha empresa. Ok
    Servidor PFSENSE:
    IP Valido: 200.103.100.25
    IP Interno: 10.0.0.1

    Tenho um outro servidor separado rodando Windows server, que tem uma aplicação WEB rodando na porta 3568.
    IP Interno: 10.0.0.2
    Para acessar internamente uso: http://10.0.0.2:3568/actWeb

    Eu fiz uma regra, para acessar o NAT externo, que quando alguém conectar pelo navegador pelo endereço http://200.103.100.25:3568 ele redireciona para o 10.0.0.2:3568, até aí tudo certo!!

    Só que se eu usar internamente (nos computadores da empresa) tentar acessar o link http://200.103.100.25:3568 ele não acessa, somente de fora.

    Resumindo:
    Fora da empresa:
    http://200.103.100.25:3568/actWeb: ACESSA

    Dentro da Empresa
    http://10.0.0.2:3568/actWeb: ACESSA
    http://200.103.100.25:3568/actWeb: NÃO ACESSA

    Alguém pode me ajudar por favor…. tá um caos aqui!

    Amigo não entendi a sua necessidade de acessar o endereço externo, sendo que você pode acessar internamente pela sua rede que seria mais rápido.

    Aqui na empresa tenha vários acessos como o que você quer fazer, vou tentar explicar como eu aplico aqui…

    meu domínio interno e externo:  www.teste.com.br

    Crio uma entrada A dizendo que webserver.teste.com.br responde em 200.103.100.25 no meu servidor de DNS externo onde o domínio está hospedado.

    Como meu dominio interno tem o mesmo nome do interno eu crio no DNS interno entrada A webserver.teste.com.br para 10.0.0.2

    No Pfsense simplesmente mantenho as regras que vc já criou... a diferença que ao invés dos usuários acessarem pelo ip iram acessar por um nome o que fica mais fácil de administrar e os usuários não percebem a diferença....



  • Esse comportamento é normal, cria uma entrada fixa no dns local apontando o endereco externo para o ip local…

    deve funcionar.

    @overflow:

    Boa tarde pessoal,
    Tenho um problema nas regras do NAT, que to batendo a cabeça e não consigo resolver, vamos lá se vcs podem me ajudar.
    Tenho um servidor PFSense que roteia a internet na minha empresa. Ok
    Servidor PFSENSE:
    IP Valido: 200.103.100.25
    IP Interno: 10.0.0.1

    Tenho um outro servidor separado rodando Windows server, que tem uma aplicação WEB rodando na porta 3568.
    IP Interno: 10.0.0.2
    Para acessar internamente uso: http://10.0.0.2:3568/actWeb

    Eu fiz uma regra, para acessar o NAT externo, que quando alguém conectar pelo navegador pelo endereço http://200.103.100.25:3568 ele redireciona para o 10.0.0.2:3568, até aí tudo certo!!

    Só que se eu usar internamente (nos computadores da empresa) tentar acessar o link http://200.103.100.25:3568 ele não acessa, somente de fora.

    Resumindo:
    Fora da empresa:
    http://200.103.100.25:3568/actWeb: ACESSA

    Dentro da Empresa
    http://10.0.0.2:3568/actWeb: ACESSA
    http://200.103.100.25:3568/actWeb: NÃO ACESSA

    Alguém pode me ajudar por favor…. tá um caos aqui!



  • Campo Nat Reflection: Enable (Nat + Proxy)



  • @santeLLo:

    Campo Nat Reflection: Enable (Nat + Proxy)

    Bahh… perfeito! é isso mesmo.... funcionou perfeitamente!

    vlw brigadão


Log in to reply