(Solved) pfSense no longer recognizes WAN/cable modem

  • Came home on New Year's Eve to find I'd had a power bump….Turn everything back on, but alas, no internet.

    Called Charter. First they blame a fiber cut. Next day got internet up and running but only when plugged directly into the modem. Now Charter's (naturally) blaming the router.

    Am using a Cisco DPC3216 to a pfSense mini pc (v 2.4.0) to an old Belkin AC750 wireless router set as an WAP.

    Have tried this equipment in various configurations (ISP to Belkin to PC/no pfSense, ISP to pfSense to PC/no Belkin), plus various re-boots and cable swaps.
    Modem shows an IP of 71...  and has no wifi or real routing capability so I'm guessing bridge mode is not the issue) The modem's web login at won't let me make any changes.

    Next planned step is to take the modem to Charter and get them to swap it out, although my gut tells me this won't help.

    I find it hard to believe both the pfSense box and the old Belkin failed simultaneously. I'm asking here because I'm hopeful someone here can help me identify the problem, or at least help me understand what I need to ask Charter for, since dealing with their phone support has been every bit as wonderful as you'd image.

    It's getting old dragging this cable around the house everytime I want to plug in....let alone the phone & the tablet! Any help is greatly appreciated!

    ![Screenshot-2018-1-5 abraxas abraxasnet home - Status Interfaces.png](/public/imported_attachments/1/Screenshot-2018-1-5 abraxas abraxasnet home - Status Interfaces.png)
    ![Screenshot-2018-1-5 abraxas abraxasnet home - Status Interfaces.png_thumb](/public/imported_attachments/1/Screenshot-2018-1-5 abraxas abraxasnet home - Status Interfaces.png_thumb)

  • …and here's a cap of the Dash that I missed in my first post.

    ![Screenshot-2018-1-5 abraxas abraxasnet home - Status Dashboard.png](/public/imported_attachments/1/Screenshot-2018-1-5 abraxas abraxasnet home - Status Dashboard.png)
    ![Screenshot-2018-1-5 abraxas abraxasnet home - Status Dashboard.png_thumb](/public/imported_attachments/1/Screenshot-2018-1-5 abraxas abraxasnet home - Status Dashboard.png_thumb)

  • Best guess… Your re0 nic is dead

  • Another guess  : the same situation : "cable modem - DHCP IP over WAN, ISP "refuses" to deliver an IP" has been seen before.

    Try this :
    Check if it is possible to put your modem in router mode. You'll be having a "router-after-router" setup, quiet normal these days.
    Also : search the forum for examples that talk about MAC cloning - some ISP want to "see" the MAC from your modem, or they see now the MAC of the WAN NIC of pfSense.
    Capture the DHCP talk on the WAN interface, so see what actually happens.

    Btw : I'm using an VDSL router myself, so I'm not using my own experiences here, just enumerating what I saw on this forum.

  • Got a new modem from Charter and was able to restore everything.

    Gonna guess some sort of DHCP issue with the old modem but I'm not smart enough to know for sure ::)

    Thanks for your replies.

Log in to reply