Traffic Totals - All VLANS collects Parent Interface data? (Solved)



  • Hi

    The problem:
      - 3 LAN interfaces: LAN (without vlan tag ); LAN1 (vlan tagged) and LAN2 (vlan tagged),
      - The telemetry  is exactly the same in the 3 LANs (this is wrong).

    Trying to fix the problem one hour ago (this tópico was created) changing all interfaces to VLANs and the same thing happens. This package is almost useless with this behavior to me.

    It seams the data is obtained on the parent interface (em1) on each interface.vlan and not in the em1.xxxx and this is not new, i think.

    pFsense build: 2.4.2-RELEASE-p1 (amd64)
    NIC: Intel(R) PRO/1000 PT (Dual)
    Package installed: Cron; freeradius3; snort and Status_Traffic_Totals 1.2.2.

    Thanks


  • LAYER 8 Global Moderator

    Could you post some actual info showing what your seeing.  I do not see the traffic the same for vlans that ride on a physical interface… While the physical interface will show the traffic that is in the vlans since it still riding on the physical interface.

    The vlans should show their specific traffic... See attached example where wlan is the physical interface and roku and psk ride on that physical interface that is untagged.






  • I think i can put some screenshots, i hope not to big.

    In "System > Advanced > Network" i have Hardware Checksum Offloading unchecked (enabled), the other offload are disabled.

    You have the interface custom names. I have the actual interface name. This has not been resolved?.

    Have you priorities on Vlans?

    ![Screenshot Tolal.png](/public/imported_attachments/1/Screenshot Tolal.png)
    ![Screenshot Tolal.png_thumb](/public/imported_attachments/1/Screenshot Tolal.png_thumb)


  • LAYER 8 Global Moderator

    No I do not have any pri set on vlans.. Something is odd there why you do not see actual names of your opt interfaces vis that .2001 and .2001, etc..

    I would prob uninstall the package and reinstall it..  Reset the data, etc.  You should see the name you put on the opt interfaces and not those .numbers for your vlans..



  • I do the question before because i do not want to reset the data and could be other problem.

    Disabling and resetting and/or disable graphing and maybe not needed to delete and reinstall the package seams solve the problem.

    Maybe a broken déjà vu but i thin i have tried this before, months ago.

    Anyway thanks for the feedback and solutions, i should know this. I will wait couple of hours and put a solved on the topic if this stay good.


Log in to reply