Unable to retrieve package information, option 13 doesn't work either…

  • On version 2.3.2-RELEASE-p1 in a VMWare ESXi virtual machine. Per the sticky thread, tried Option 13 from console, and it detected some out of date packages and said 129MB would be downloaded. Then I got:

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) Y
    >>> Unlocking pkg... done.

    Then it returned to the usual console menu. Not sure which logs to check or where to look for them. It's otherwise functioning fine - passes traffic, VPN clients can connect. But I can neither add new packages nor upgrade….

  • Rebel Alliance Developer Netgate

    If you run "pkg update -f" what output do you see?

    If you go in the GUI to System > Update, Update Settings tab, try switching to a different branch, such as a development snapshots branch, save, then switch back to the setting you had to start with and save again. Does it work after that?

  • # pkg update -f
    Shared object "libssl.so.8" not found, required by "pkg"

    So I'm missing the SSL library? That's …. weird. Any way I can restore it?

    Switching to a different branch, saving, then switching back to the stable branch made no difference.

    EDIT: Here's another interesting tidbit.

    # find / -xdev -iname "libssl.so.*"

    So it appears I have libssl, just the wrong version. In the wake of Meltdown, I tried to update a few days ago and thought it succeeded, but it must have gone awry. Any idea how to get the proper version on my VM?

  • Rebel Alliance Developer Netgate

    Your system has picked up the pkg binary from 2.4 as part of the upgrade. It should work OK with pfSense-upgrade, but you might need to do this first:

    pkg-static update -f
    pkg-static upgrade -fy pkg pfSense-repo pfSense-upgrade

    And then run

    pfSense-upgrade -d

  • After following your steps, "pfSense-upgrade -d" results in the package manager finding 129MB to download, then this:

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) Y
    >>> Unlocking pkg... done.
    Unlocking pkg-1.10.1_1

    EDIT: libssl.so.8 is still not present…

  • So I waited for a while and tried updating manually again. This time it seemed to work. Packages downloaded and installed and the system rebooted. However, when it came back up the console screen was filled with "PHP Startup: Unable to load dynamic library". Most of these were referencing libcrypto.so.8 and libssl.so.7. I managed to fix those with some judicious  symlinks. However, two errors are still preventing PHP from starting up:

    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/readline.so' - Shared object "libreadline.so.8" not found, required by "readline.so" in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/zmq.so' - /usr/local/lib/libsodium.so.18: Undefined symbol "explicit_bzero" in Unknown on line 0

    I have no idea what to try next. I tried the manual update process you outlined above, but it still leaves me in this state. Any suggestions?

  • Never mind, it was easier to just do a fresh install of 2.4.2 than trying to recover from this mess. I will now have to reinstall OpenVPN on a few laptops, and hope that I configured the VPN properly.

    If only…need to remember to do a snapshot next time I contemplate an upgrade. But they usually go so smoothly there hasn't been a need.

Log in to reply