Having trouble installing php72-7.2.1.txz package



  • Hello guys,
    I'm trying to install a package but am getting this error when it's done.

    pkg: php72-7.2.1 conflicts with php566-5.6.32 (installs in the same path). problematic file: usr/local/bin/php
    

    any help fixing this will be much appreciated.



  • Hi,

    Your lucky. The answer is simple. You can't do that.
    pfSense is using itself PHP for the GUI.
    There are probably many lines in the scripts of the GUI that wouldn't be compatible with PHP 7.2.

    Btw : this is like asking how to install core Windows 10 files on a Windows 8 PC. Experts can't (and won't ask the question).


Log in to reply