Coreboot update equivalent for non-netgate APU2



  • All,

    For my personal home router I started with an official Netgate APU2 with 2GB RAM, I then transferred to a non-Netgate PC Engines 4GB APU2 (same hardware) and upgraded to a 32GB SSD (Not SD Card).

    The core boot version is 4.0 dated Mon Sep 8 2014 which I suspect is out of date. Obviously the Netgate core boot update doesn't recognize this as Netgate hardware.

    While I'm an intermediate level Linux and FreeBSD and pfSense hacker, I'm completely unfamiliar with coreboot other than conceptually.

    Has anyone else done this and/or got an Idiot's Guide to updating coreboot? I've already checked and PC Engines doesn't offer coreboot upgrade binaries in their support section.

    Alternatively, although I'm a little strapped for cash right now being between employers: If I signed up for Netgate's Gold subscription could Netgate be persuaded to support my hardware for a core boot upgrade?

    I do still have my original Netgate 2GB APU2 to practice on.

    TIA!

    James



  • You can find the coreboot binaries from PC Engines here:
    http://pcengines.ch/howto.htm#bios

    The page is slightly out of date, listing  4.0.11 as the latest version in the 4.0.y series, as they already have 4.0.12 (dated August 2017) available for download:
    http://pcengines.ch/file/apu2_v4.0.12.rom.tar.gz
    Edit: That is the wrong file for the Netgate "APU2" - Steve

    Just decompress the tar.gz archive and you will find the rom file inside (if you are on Windows you can use the tool "7-Zip" to decompress the archive).

    Personally, I'd stay away from the newer 4.6.y coreboot version on the APU2 for now as users have reported various issues with it.

    Btw. I haven't upgraded coreboot on the APU2 from within pfSense yet. AFAIK, it should be possible, but I never tried. I just used the method suggested by PC Engines which is booting TinyCore Linux from a USB drive and writing the rom image from there. But I think I've seen reports of users doing this with pfSense instead.


  • Netgate Administrator

    The Netgate coreboot update package doesn't support the APU. It only updates the ADI hardware. I can't see that changing.

    You should be able to update the APU from within pfSense using the standard flashrom package though. Any updates will be from PCEngines directly as linked above.

    Note however that the Netgate APU2 was so named because it had 2GB of RAM and is in fact a PC Engines APU1. So it would appear you are already running the most recent BIOS available on the Netgate device at least.

    Steve



  • @Steve: I think you misread the initial posting. My link was correct. He specifically asked for the PC Engines APU2, not the Netgate APU2 (even though one can easily get confused because he mentions using the Netgate APU2 before).


  • Netgate Administrator

    Yeah, I did misread it initially. But he said his other device is the same hardware so I stuck to it. If his current BIOS is dated 2014 I believe it must be the first APU model.

    My intent was only to make sure he is using the right bios image. I imagine flashrom would complain if you try to the the wrong one but I've never tried that and I'm not about to risk it!  ;)

    Steve



  • Yes, my initial (and now backup) unit is a Netgate APU2 with 2GB of RAM. I replaced it with a 4GB unit and M2 SSD from PCEngines, with the SD card as a backup boot device.

    The 4GB unit that I'm interested in updating in the pfSense CE System Information widget identifies itself as a "Netgate APU" Weirdly enough, and the BIOS section shows:

    Vendor: coreboot
    Version: 4.0
    Release Date: Mon Sep 8 2014

    Does anyone know which 4.0.X version that date code corresponds to? Can I get that out of flashrom somehow? Is it on the boot console stream? I haven't looked at that in a while, is it there?

    James


  • Netgate Administrator

    4.0.1 is dated  2016-09-12 so if your current version is from 2014 I would say that is almost certainly also a 1st gen board.

    You should be able to see the CPU type on the dashboard in pfSense. The APU1 had a T40E.

    CPU Type: 	AMD G-T40E Processor
    2 CPUs: 1 package(s) x 2 core(s) 
    

    Steve



  • I think you’re most likely correct. I can’t remember exactly when I bought the board but it was a few years ago. Here’s the section from the widget:

    CPU Type AMD G-T40E Processor
                    2 CPUs: 1 package(s) x 2 core(s)
                    AES-NI CPU Crypto: No


  • Netgate Administrator

    Yeah that's an APU1. I'd say you're already on the most recent BIOS for that then.

    Was there something in particular you wanted to address by updating the BIOS?

    Steve



  • Just Double-checked. Yup RealTek NIC ports, not Intel, Definitely a 4GB APU, not an APU2. 14082014 is the most recent listed by PCENgines at http://pcengines.ch/howto.htm#coreboot

    My Bad, sorry for the confusion. No real motivation, the BIOS just seemed a little elderly and in these days of Meltdown and Spectre it prompted me to go looking for firmware updates.

    <self administered="" facepalm="">:-[</self>



  • @daplumber:

    My Bad, sorry for the confusion.

    you're not the one who decided to rename a third party product with a name that (unsuprisingly) was later used by a different version of the third party's hardware. it's been confusing people for years.


Log in to reply