Duda Sobre Squid



  • Buenas Noches, buena mi pequeña duda es sobre el squid ya que todo funciona al casi digamos que al 100% solo que cuando descargo no me funciona al 100% la conexion porque en mi caso tengo una conexion adsl de 1024 osea mi descarga al 100% de la conexion establemente es a 110Kbps x seg, pero luego de montar squid y configurarlo sin nada de control de ancho de banda ni nada solo pfsense 1.2.1 + squid, cuando me pongo a bajar archivos me descarga a 30 kbps a 18, varia hay momento en que me esta a los 110kbps pero luego baja a 60 no es estable al 100% pero el squid para navegar y chachear todo funciona bien solo es para la descarga de archivos pero para cargar la paginas u otras cosas si funciona al 100%

    Gracias salu2 espero una pronta respuesta gracias

    mi version de Squid que utilizo es la 2.6 STABLE
    y la de pfSense es la 1.2.1 final



  • ¡Hola!

    La velocidad de descarga de un archivo depende de muchos factores, no sólo del cortafuegos (pfSense) y de si tienes un proxy (squid) que cachea el archivo bajado o no.

    Cuando descargas un archivo estás accediendo a un servicio externo y la velocidad depende de la utilización del servidor donde se encuentra el archivo y el ancho de banda disponible entre el servidor y tu equipo.

    También depende de con qué descargas el archivo. Lo más lento es hacerlo con Iexplorer, Firefox suele ser más rápido y wget (una utilidad GNU que también se puede instalar en Windows) mucho más rápida aún.

    Si tienes dudas, haz pruebas con un equipo directamente colgado de tu router ADSL …

    Saludos,

    Josep Pujadas



  • si ese es el detalle que al estar conectado directamente a mi adsl bajando un archivo se pega a toda mi conexion, pero luego lo pongo al pf sin squid funciona bien tambien utiliza toda mi conexion, pero ya cuando le monto al pf squid ya mi conexion empieza a bajar :( no se porque lo e configurado lo dejo de fabrica y nada :/ e probado en varios pcs distintas tarjetas de red y nada nunca es estable al 100%, y normalmente descargo mis archivos con flashget ya que tengo un LoadBalance antes de mi pf con squid  para poder utilizar mis 2 adsl, gracias Sr. Josep



  • ¡Hola!

    ¿Cuáles son las características de la máquina donde tienes pfSense con squid? Piensa que si estás pasando por squid la velocidad de respuesta depende de éste y también está en función de si el objeto pedido está guardado o no en el disco duro (caché).

    No conozco flashget pero tampoco parece que tenga nada raro en cuanto al uso de proxyes con él, http://www.flashget.com/en/faq002.htm

    ¿El balanceo lo hace el mismo pfSense donde está squid? ¿Probaste sin balanceo?

    Saludos,

    Josep Pujadas



  • bueno mi balanceo esta montado aparte, porque tengo claro que realmente el balanceo no puede estar junto a squid ni a el control de ancho de banda, mi pf con squid lo e montado en un pemtiun d 3.2ghz 4 mb cache, 4 gb de ram, hdd 160 sata (e probado con un ide tambien) tarjeta madre intel, tarjetas de red intel pro 100 ve de lan(integrada), y una tarjeta nexxt para la wan(pci), tarjeta madre intel…..

    tambien lo e probado con un core 2 duo e6300@1.86ghz con 2 mgs de cache, 1 gb de ram, 10gb de hdd, tarjeta de red d-link con chip via para la (wan) y una realteck para la (lan) realmente no se que podra ser  :( y un amigo tiene montado el traffic share junto con squid y su descarga funciona al 100%, pero no se porque a mi no me va, bueno tambien e probado con firefox, con el ie directo sin ningun programa de descarga y no funca al 100% mi conexion luego de estar pasando x el squid..!!

    gracias Sr. Josep



  • ¡Hola de nuevo!

    Bueno, parece que no son los equipos. Son más que correctos …

    Tendrías que mirar en los logs de pfSense y especialmente en los estados, a ver si hay algo raro.

    Saludos y ¡suerte!

    Josep Pujadas


Locked