Problema no Pfsense 2.4 com Failover + Squid3.5



  • Bom dia a todos, estou enfrentando problema ao tentar realizar o failover das minha WANs utilizando o squid.
    O cenário é o seguinte: possua duas WANs e mais 4 Lans ( Vlans), já configurei o grupo de gateway com as duas Wans, bem como
    as regras no firewall com o grupo de gateway failover. Quando o link principal fica down os usuários continuam acessando a internet
    se estiverem sem o proxy, mas caso eu habilite o proxy, eles não conseguem navegar. Pois, o proxy fica enviando as requisições para
    o gateway default, que é o link principal. Já fiz diversos procedimentos descritos em outros tópicos, tais como: criação de um regra flutuante
    e adicionar o tcp_outgoin_address no squid, mas nada fez funcionar com o bendito squid. Talvez essas soluções não funcionem com as versões
    do pfsense e squid que estou a utilizar. Alguém teria alguma outra alternativa para o problema ?



  • Vá em System > Advanced > Miscellaneous e marque a opçao Enable Default Gateway Switching. Assim quando o gateway default ficar offline… ele trocará o gateway default. Deixe a regra do squid com gateway default e funcionará.



  • Eu já tentei essa opção, porém eu tenho outros gateways de outras lans. Eu coloquei a imagem em anexo com o cenário da minha rede, quando a WAN cai ele vai para o gateway impressoras, conforme eu vou desativando ele vai seguindo essa sequência. Eu não encontrei onde alterar a sequência dos gateways, pois se conseguisse acredito que iria funcionar.

    ![Sem título.png](/public/imported_attachments/1/Sem título.png)
    ![Sem título.png_thumb](/public/imported_attachments/1/Sem título.png_thumb)



  • Pq vc precisa cadastrar o gateway pra uma rede LAN?



  • Cada LAN na verdade é uma VLAN, o que eu poderia alterar para prover comunicação entre elas ?


Log in to reply