WAN Gateway showing offline and incorrect IP assigment

  • My WAN gateway which is the default gateway for my WAN interface, using a PPPoE connection to my ISP (BT Infinity) connection via a Draytek 130 modem, is showing offline with a Loss of 100%.

    The IP address assigned to the gateway as shown in the attachment is not my public IP address but I believe that it should be? I do however have a working internet connection and my WAN interface correctly shows my assigned public IP address.

    Please could someone suggest how I might correct this gateway problem? Many thanks in advance.

  • The WAN gateway IP must never be the same as the WAN IP. The WAN GW (upstream GW) is the device at your ISP, where your pfSense sends all the upstream traffic to to be forwarded to the internet.
    Ergo if you have internet access the gateway is reachable and it works.

    That is is shown as offline only means that it doesn't response to pings. pfSense use pings (dpinger service) to determine the gateway status.
    If you want get rid of the "Offline" status you may either deactivate monitoring of this gateway or just set another IP address in the internet which responses to pings for monitoring.
    Both can be done in System > Routing > Gateways > Edit WAN_PPPOE
    Either check "Disable Gateway Monitoring" or enter another IP for monitoring at "Monitor IP".

  • Thank you viragomann. I was surprised to discover that the Wan gateway IP assigned to me by my ISP, BT, doesn't resemble at all their assigned public WAN IP. I assumed that this address would be from the same subnet.

  • @simon-lock I thought so too!
    My WAN IP is 87.6.208.xx, whereas my WAN Gateway is
    Aren't they supposed to be on the same subnet?
    By the way, my WAN connection is PPPoE.
    With my previous ISP, my WAN gateway was on the same subnet as my WAN IP.

  • A lot of ISPs run private networks that route public addresses to their customers. My WAN IP is 209.x.y.z and my upstream is also on 209.x.y.z-1, but it all connects to a network.

Log in to reply