[solved] After activating Proxy (Squid) I can no longer browse or ping url

  • I am a beginner in Pfsense and I ask the help of colleagues to try to guide me how to solve the following problem:

    A few minutes after activating the proxy service (Squid Proxy Server and SquidGuard) with authentication on an AD (Active Directory) server, I can no longer ping any url (Example: www.google.com), I also can not navigate to multiple sites . That is, you can only ping addresses like or
    As soon as you disable the "Squid Proxy Server", everything returns to normal.

    Within my limitations I made several checks such as: DNS Resolver, DHCP Server and etc. And these services continue to work when the problem occurs.

    I even activated the "DNS Forwarder" to see if it resolves. But it did not.

    Some data from my firewall:

    • Pfsense version: 2.4.2-RELEASE-p1 (amd64));
    • It has 4 physical network cards with different IP ranges (nfe0 = LAN, rl0 = DMZ, re0 = link provider 1, re1 = link provider 2). The last two network adapters have failover and load balance service enabled.
    • OpenVPN enabled too (no issues)

    I strongly urge friends to tip and also to know if anyone has passed or is going through this situation.

    Thanks in advance.


  • When you install Squidguard, its default behaviour is to block everything until you edit the Target Rules list of the Common ACL and set the default access from Deny to Allow..

    Questions about squid/squidguard are best posted in the Cache/Proxy forum.

  • Hi!

    The target (common ACL) rules in SquidGuard are as "allowed".

    Obs.1: The problem occurs a few minutes after activating the "Squid Proxy Server" service.

    Obs.2: The next topic I will add in "Cache / Proxy forum"


  • After to clear the cache, the problem was solved.


Log in to reply