Need to know how people make their webservers visible over the net with pfsense



  • how do i put this since this is my first post here? I have the webserver feature turned on with my nas box. It has freenas on it. since port 80 is taken for some reason, I have bound the webserver to port 8080. It says port 8080 is closed at the site yougetsignal.com. That explain why I only get the router interface prompt when i go to my dynamic dns url myfreenas.kicks-ass.org. What i dont understand is why this is going on. I have screen shots of what i have right now on my pfsense config that i am uncertain of and of what happens when i try to bind the webserver part to port 80. What i want is to get the freenas prompt instead of the router prompt. I have musicbrowser's folder php script on my hdd share already. It should allow me to stream my music like how you can stream videos on sites like youtube which is the desired outcome. If anyone can point me to some link and/or take a look at the the picture and tell me what i am doing wrong, That would be appreciated. The sooner you answer the better. P.S. I have 6 pictures to show what happens but cant fit them all in one post.
    ![Screenshot-myfreenas.local - Services|Webserver - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-myfreenas.local - Services|Webserver - Swiftfox.jpg)
    ![Screenshot-myfreenas.local - Services|Webserver - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-myfreenas.local - Services|Webserver - Swiftfox.jpg_thumb)
    ![Screenshot-pfSense.local - Firewall: NAT: Port Forward - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-pfSense.local - Firewall: NAT: Port Forward - Swiftfox.jpg)
    ![Screenshot-pfSense.local - Firewall: NAT: Port Forward - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfSense.local - Firewall: NAT: Port Forward - Swiftfox.jpg_thumb)



  • here are more photos

    ![Screenshot-pfSense.local - Firewall: Rules - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-pfSense.local - Firewall: Rules - Swiftfox.jpg)
    ![Screenshot-pfSense.local - Firewall: Rules - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfSense.local - Firewall: Rules - Swiftfox.jpg_thumb)
    ![Screenshot-pfSense.local - Services: DHCP server - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-pfSense.local - Services: DHCP server - Swiftfox.jpg)
    ![Screenshot-pfSense.local - Services: DHCP server - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfSense.local - Services: DHCP server - Swiftfox.jpg_thumb)



  • and the last of them :)

    ![Screenshot-pfSense.local - Services: DNS forwarder - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-pfSense.local - Services: DNS forwarder - Swiftfox.jpg)
    ![Screenshot-pfSense.local - Services: DNS forwarder - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfSense.local - Services: DNS forwarder - Swiftfox.jpg_thumb)
    ![Screenshot-pfSense.local - System: General Setup - Swiftfox.jpg](/public/imported_attachments/1/Screenshot-pfSense.local - System: General Setup - Swiftfox.jpg)
    ![Screenshot-pfSense.local - System: General Setup - Swiftfox.jpg_thumb](/public/imported_attachments/1/Screenshot-pfSense.local - System: General Setup - Swiftfox.jpg_thumb)



  • The screenshots are too small to read.

    Wild guess: You're trying to access the internal IP via the public IP (dns-name)
    Enable NAT reflection for that:
    http://forum.pfsense.org/index.php/topic,7001.0.html



  • have you tried enlarging the images? I would make them bigger if there was not a 250mb limit on uploads


Locked