Clamd Clamav Antivirus não inicia



  • Boa tarde caros,

    Estou utilizando a versão 2.4.2-RELEASE-p1 (amd64) e o serviço clamd (ClamAV Antivirus) não inicia de nenhuma forma.

    Isso me causa problemas de conexão em alguns sites onde recebo a seguinte mensagem:

    _ERRO
    A URL requisitada não pôde ser recuperada
    O seguinte erro foi encontrado ao tentar recuperar a URL: http://www.correioweb.com.br/

    Erro de protocolo ICAP.
    O sistema retornou: [No Error]
    Isto significa que alguma característica da comunicação ICAP falhou.
    Alguns dos possíveis problemas são:
    O servidor ICAP não é alcançável.
    Uma resposta ilegal foi recebida do servidor ICAP._

    Pesquisei que para esse caso era necessária a atualização do ClamAV, mas ao rodar o comando freshclam recebo o seguinte retorno:

    ClamAV - freshclam Logs
    Message
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)
    safebrowsing.cld is up to date (version: 46966, sigs: 3098322, f-level: 63, builder: google)
    daily.cld is up to date (version: 24273, sigs: 1840848, f-level: 63, builder: neo)
    main.cvd is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    DON'T PANIC! Read http://www.clamav.net/documents/upgrading-clamav
    WARNING: Local version: 0.99.2 Recommended version: 0.99.3
    WARNING: Your ClamAV installation is OUTDATED!
    ClamAV update process started at Wed Jan 31 16:35:14 2018
    –------------------------------------
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)

    O que pode estar havendo?



  • @aldo.lisboa:

    Boa tarde caros,

    Estou utilizando a versão 2.4.2-RELEASE-p1 (amd64) e o serviço clamd (ClamAV Antivirus) não inicia de nenhuma forma.

    Isso me causa problemas de conexão em alguns sites onde recebo a seguinte mensagem:

    _ERRO
    A URL requisitada não pôde ser recuperada
    O seguinte erro foi encontrado ao tentar recuperar a URL: http://www.correioweb.com.br/

    Erro de protocolo ICAP.
    O sistema retornou: [No Error]
    Isto significa que alguma característica da comunicação ICAP falhou.
    Alguns dos possíveis problemas são:
    O servidor ICAP não é alcançável.
    Uma resposta ilegal foi recebida do servidor ICAP._

    Pesquisei que para esse caso era necessária a atualização do ClamAV, mas ao rodar o comando freshclam recebo o seguinte retorno:

    ClamAV - freshclam Logs
    Message
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)
    safebrowsing.cld is up to date (version: 46966, sigs: 3098322, f-level: 63, builder: google)
    daily.cld is up to date (version: 24273, sigs: 1840848, f-level: 63, builder: neo)
    main.cvd is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    DON'T PANIC! Read http://www.clamav.net/documents/upgrading-clamav
    WARNING: Local version: 0.99.2 Recommended version: 0.99.3
    WARNING: Your ClamAV installation is OUTDATED!
    ClamAV update process started at Wed Jan 31 16:35:14 2018
    –------------------------------------
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)

    O que pode estar havendo?

    Já vi casos que se reinstalar o pacote Squid, já resolve o Clamav.
    Faça um teste.



  • Bom dia prezado,

    Já havia tentado uma reinstalação sem sucesso ontem, hoje realizei uma remoção completa e nova instalação e novamente tenho o mesmo erro:

    ClamAV update process started at Thu Feb  1 11:52:07 2018
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.99.2 Recommended version: 0.99.3
    DON'T PANIC! Read http://www.clamav.net/documents/upgrading-clamav
    main.cvd is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    daily.cld is up to date (version: 24275, sigs: 1841355, f-level: 63, builder: neo)
    safebrowsing.cld is up to date (version: 46969, sigs: 3097928, f-level: 63, builder: google)
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)



  • @aldo.lisboa:

    Bom dia prezado,

    Já havia tentado uma reinstalação sem sucesso ontem, hoje realizei uma remoção completa e nova instalação e novamente tenho o mesmo erro:

    ClamAV update process started at Thu Feb  1 11:52:07 2018
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.99.2 Recommended version: 0.99.3
    DON'T PANIC! Read http://www.clamav.net/documents/upgrading-clamav
    main.cvd is up to date (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    daily.cld is up to date (version: 24275, sigs: 1841355, f-level: 63, builder: neo)
    safebrowsing.cld is up to date (version: 46969, sigs: 3097928, f-level: 63, builder: google)
    bytecode.cvd is up to date (version: 319, sigs: 75, f-level: 63, builder: neo)

    Boa tarde,

    Verifique se o seu firewall consegue acessar "database.clamav.net", caso não consiga providencie a liberação.

    Verifique também se há alguma coisa no log do clamd e veja se tem uma saída parecida com esta abaixo:

    Reading databases from /var/db/clamav
    Database correctly reloaded (6401940 signatures)
    Reading databases from /var/db/clamav
    Database correctly reloaded (6401940 signatures)
    SelfCheck: Database status OK.
    SelfCheck: Database status OK.
    SelfCheck: Database status OK.



  • Depois que você habilita o clamav você faz o update dele? Posta suas configurações também (print).