Femtocell higher priority on LAN to WAN and WAN to LAN - how to do it ?



  • I have a T-Mobile femtocell as well as a T-Mobile LineLink on my LAN that I want to give priority.

    The femtocell is a small low power cell site that allows cell calls, text and data over the internet using the standard cell phone.
    The LineLink is like a voip adapter that has a POTS socket and connects over the internet, creates a home phone connection.

    I tried to use the wizard - Multiple Lan/Wan, using all defaults and I used the local IP address of the femtocell 192.168.1.101 for now.
    I created an alias for both IP address, after I get a single IP working.

    I changed it to 'any' protocol. I tried it with any source and also with the source as WAN net, WAN address, and with them as the destination too. See the images.

    With my cell phone connected to the femtocell (with the phone's Wifi disabled), I did a speedtest.

    I looked on the queues, I saw no Voip traffic at all.  On this page: http://192.168.1.1/status_queues.php

    Using PRIQ.

    Any tips for me, for what I'm going wrong?

    I did do other tests where I used Low/normal/High  for application/protocols using PRIQ, they seemed to work ok and I saw those going into the correct queues.










  • Posting how I got it working, incase it helps someone else in the future.

    It was my error of course. When I enabled the traffic shaper and the rules, I just needed to reset the state table of all current connections.

    I could either reset all states [ http://192.168.X.X/diag_resetstate.php ], or just the states that applied to the devices on my LAN using the filter [ http://192.168.X.X/diag_dump_states.php ].
    Both worked.

    I created an alias call VoipHosts that included the IP address for both T-Mobile devices.

    I edited the floating rule that was created by the wizard, changed it to include all protocols instead of the default UDP only protocol.
    At least the LineLink uses both UDP and TCP.

    This site here really helped. http://pfsensesetup.com/category/setup-guides/

    That says this:

    Traffic shaping should now be activated for all new conections. However, existing connections will not have traffic shaping applied to them, only new connections. In order for traffic shaping to be fully active on all connections, you must clear the states. In order to do this, navigate to Diagnostics -> States. Then click the Reset States tab, check the Firewall state table check box (if it is not already checked), and press the Reset button.