WebUI / nginx no response but SSH fine [SOLVED]

  • Hi,

    on a small branch pfsense I encountered a strange problem I never had before.
    If I try to connect to web UI the session always times out, no changes to the FW were made it just started to show this behavior randomly.

    SSH Login on the other hand is fine, if I restart webconf and php-fpm by console still the same problem. Routing FW and setup VPN seems to work without any Problem but no UI anymore.

    If I take a look at the nginx log files the strang thing happens, Nginx log is empty only showing some unreadable ASCII Chars.

    A nginx -t is fine also nginx process is running. If I manually kill it and start  nginx -c /var/etc/nginx-webConfigurator.conf  no error is reported too.

    Any Tipp or suggestion for me would be apreciated, currently is a bad time to reset and reconfigure the whole thing :)

    Thanks alot.

  • The syslogger is using binary, fixed size log files.
    The format is "clog" (probably from circular log). You should use the clog command to see these files.
    Like this

    clog /var/log/nginx.log

    pfsense log files  ;)

    Btw : pfSense is often installed on devices with very limited storage. Log files, if not maintained, tend to become very big, and this makes the device running out of memory. Thus the  fixed size, circular log files.

  • thanks, never worked with bin logs before.

    But found the problem, pfsense was only running on 443 and somehow the internal CA was missing nginx couldnt load. Changed via viconfig to enable port 80 http, recreated a cert and done.

    • solved -

Log in to reply