PfSense 2.4.2-RELEASE-p1(amd64) Package Manager available package is unavailable



  • Hi,

    Today I installed pfSense 2.4.2-RELEASE-p1(amd64) (after installation it asked me to update).

    If I see the Package Manager - Available Package is Unavailable (pfSense 2.4.2-RELEASE-p1(amd64) Package Manager available package is unavailable)

    Please find the attachment for your reference.

    So please help me to solve this issue.

    Thanks in advance.

    Lokesh Kamath

    ![Available Package.png](/public/imported_attachments/1/Available Package.png)
    ![Available Package.png_thumb](/public/imported_attachments/1/Available Package.png_thumb)



  • @slkamath:

    Today I installed pfSense 2.4.2-RELEASE-p1(amd64) (after installation it asked me to update).

    You have this one :

    2.4.2-RELEASE-p1 (amd64)
    built on Tue Dec 12 13:45:26 CST 2017
    FreeBSD 11.1-RELEASE-p6
    
    The system is on the latest version.
    Version information updated at Wed Feb 14 16:04:16 CET 2018  
    
    

    and it proposes an upgrade ?
    Upgrade to what ? a dev version ?

    2.4.2-RELEASE-p1 (amd64) is the latest stable version.

    @slkamath:

    If I see the Package Manager - Available Package is Unavailable (pfSense 2.4.2-RELEASE-p1(amd64) Package Manager available package is unavailable)

    When you installed pfSense, did you change anything related to DNS ?
    Also : access the console and type

    host google.com
    

    did it resolve ?

    Btw : no, the update servers are not down. I can sync with them just fine.



  • Hi

    Thanks for replying.

    Upgraded to 2.4.2-RELEASE-p1(amd64).

    I tried running the below command, after that package manager is not showing.

    echo 'dnsthingy:{url: "https://storage.googleapis.com/downloads.dnsthingy.com/pfsense/pkg/'uname -m'",enabled: yes}' > /usr/local/etc/pkg/repos/dnsthingy.conf

    I tried this before upgrade and tried after upgrade to 2.4.2-RELEASE-p1. No luck. SO i think problem with the command.

    Once again thanks for replying.

    Lokesh Kamath



  • @slkamath:

    I tried running the below command, after that package manager is not showing.
    echo 'dnsthingy:{url: "https://storage.googleapis.com/downloads.dnsthingy.com/pfsense/pkg/'uname -m'",enabled: yes}' > /usr/local/etc/pkg/repos/dnsthingy.conf
    I tried this before upgrade and tried after upgrade to 2.4.2-RELEASE-p1. No luck. SO i think problem with the command.

    You are poking files into /usr/local/etc/pkg/repos …
    Something coming from "googleapis.com" ....
    "dnsthingy"  :o
    At least I'm sure now something isn't working well.


Log in to reply