UNDEF OPEN VPN



  • Olá pessoal boa noite

    peço uma ajuda ao Fórum, criei um servidor VPN possuo duas placas de Rede na WAN pega um IP Público a outra placa está ligada na LAN.
    existe comunicação externa pela internet normalmente.

    Configurei a CA e o Certificado normalmente e fiz a instalação do servidor pelo wizard e instalei o pacote de exportar clientes.

    exportando cliente pro android conecta normalmente na rede que está o servidor como também conecta normalmente para o windows 10 dentro da rede que está o servidor, eu tentando acessar pelo celular usando os dados móveis na dashboard do PfSense mostra o IP da conexão 4G porém em nome comum fica UNDEF e no status do celular não mostra como conectado, mesma coisa é no computador

    Thu Feb 15 22:33:41 2018 OpenVPN 2.3.18 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Sep 26 2017
    Thu Feb 15 22:33:41 2018 Windows version 6.2 (Windows 8 or greater) 64bit
    Thu Feb 15 22:33:41 2018 library versions: OpenSSL 1.0.2l  25 May 2017, LZO 2.10
    Thu Feb 15 22:33:51 2018 Control Channel Authentication: using 'VPN-udp-1194-gti-tls.key' as a OpenVPN static key file
    Thu Feb 15 22:33:51 2018 UDPv4 link local (bound): [undef]
    Thu Feb 15 22:33:51 2018 UDPv4 link remote: [AF_INET]xxx.xx.xx.xx:1194

    (o ip público substitui pelo x)

    Então já executei como administrador, já olhei as portas no PfSense protocolo UDP porta 1194 liberado na WAN todas as portas liberadas na interface Open VPN, enfim rsrsrs preciso de ajuda



  • Não está muito claro. A conexão na VPN só não funciona quando você está utilizando o 4G?

    Quanto ao argumento 2018 UDPv4 link local (bound): [undef] - aqui tenho o mesmo na conexão do cliente, esse parâmetro undef no caso, porém funciona normalmente. Nos logs do firewall não mostra nada? Já experimentou restartar o service?



  • No 4G foi um teste que fiz pois dentro da rede interna do servidor a VPN conecta sem nenhum problema
    então tentei pela rede externa que  foi uma conexão 4g e deu este problema essa mensagem que eu postei

    agora pouco pedi para um colega de outra cidade também tentar se conectar e mostra o mesmo erro

    resumindo dentro da rede interna eu consigo me conectar mas na rede externa aparece essa mensagem no computador cliente e no servidor mostra como UNDEF e não acessa aos recursos da rede

    tentei também no celular na rede conecta aparece a chave na área de notificação quando acessando dentro da rede interna que está localizado o servidor, porém quando desabilito o wifi e vou conectar pelo 4g não aparece o status de conectado no celular mas no servidor mostra o IP Público de oriegem com a conexão UNDEF

    vou verificar os logs do firewall e vou tentar restartar o serviço

    Obrigado pela a atenção



  • No pfSense em Status -> System logs -> OpenVPN, o que mostra quando é feita a conexão do cliente?



  • UNDEF xxx.xxx.xx.xx Fri Feb 16 15:00:58 2018 480 B / 270 B
    Status: Actions:

    Mostra da forma como está acima (onde os "X" é o IP da origem)



  • Estou usando a Versão 2.4.2-RELEASE (amd64)



  • jao_mezari

    Obrigado pelas dicas descobri a problemática

    como eu disse no começo tenho duas placas uma LAN e uma WAN

    na Lan tem GW mesmo eu selecionando "NONE" estava dando este problema após eu apagar o GW da lan nas configurações de IPV4 o open vpn se conectou que foi uma beleza  8)

    Demorou mas resolveu hehehe

    a placa de rede LAN tem apenas endereço IP e mascára de subrede sem GW

    todo o tráfego fica pelo endereço da WAN


Log in to reply