2.3.2-RELEASE-p1 cannot see newer upgrades?



  • I've been lax with updates at a remote site and went to try to rectify that, and the firewall insists it is on the latest version.

    The dashboard showed a 2.3.3 update being available, but clicking on update led to the actual update page where it insists 2.3.2-Release-p1 is the latest.

    I then logged in via SSH and did "pkg update; pkg upgrade -fy pkg" which found almost nothing to update. After that, I ran "pfSense-upgrade" from the shell and it updated a bunch of components.

    When the firewall came back up, it's still telling me it is 2.3.2-Release-p1 and there is no way to upgrade that.

    On the command line I tried to upgrade again (with option 13) and it finds nothing.

    Is the GUI out of sync with reality, ie is the firewall 2.3.3 something now under the surface, or did it not upgrade?

    The CLI:

    1. Logout (SSH only)                  9) pfTop
    2. Assign Interfaces                10) Filter Logs
    3. Set interface(s) IP address      11) Restart webConfigurator
    4. Reset webConfigurator password    12) PHP shell + pfSense tools
    5. Reset to factory defaults        13) Update from console
    6. Reboot system                    14) Disable Secure Shell (sshd)
    7. Halt system                      15) Restore recent configuration
    8. Ping host                        16) Restart PHP-FPM
    9. Shell

    Enter an option: 13

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Your packages are up to date
    *** Welcome to pfSense 2.3.2-RELEASE-p1 (amd64 full-install)


Log in to reply