Odd problem can't login to most ssl sites or post, only affects the linux boxes.

  • Hi there,

    :( I have a really annoying issue that has been wracking my brain for quite some time now. I'm unable to to login to ssl
    enabled sites when behind the pfsense router using a linux machine. The website loads up but when I go and click to login it
    starts to connect and then hangs on waiting for the site to load but it never loads it just times out or I get a connection was
    reseted error. I know the site is not the problem because it loads fine on the windows machines on the same network, it only
    seems to affect my linux boxes. I have tried using different web browsers but it's the same with all of them. The only site I can
    access without any issues is google's gmail. With ebay its even stranger after a long time I get a download dialog for a file
    called ebayISAPI.dll  ??? (which is just a 0 byte file for the curious). The timeout issue also happens if I try to post to some sites
    even non ssl sites like for example to this forum. I had to connect through my 3g modem in order to post this because upon
    clicking the post or preview button it would stay connecting and then timeout.

    I tried booting the machines with  recent livecds (tried various distros) but I still get the issue as long as it is connecting
    through the pfsense router. If I connect the machine directly to the Internet or through another network with no pfsense in the
    middle it has no problem login into the sites. I even booted the router using the pfsense livecd version 1.2.1 and only changing
    the configuration for the WAN and the problem persists.

    I have gone as far as installing various different distros in a few of my machines and all have the same issue when behind the
    pfsense router. If I replace the pfsense router with a non pfsense one everything works fine but I'd prefer to use the pfsense
    router for its better interface and some features I want to test out but have been unable to until I resolve this issue.

    My setup is quite simple:

    ISP ADSL (PPPoA only)  ->  Draytek Vigor Modem (PPPoE to PPPoA bridge) ->  Pfsense  ->  Network Switch  - >

        3 Windows Workstations,
        1 Linux Workstation,
        4 Linux Servers,
        2 Linux Laptops,
        2 Windows Laptops,
        3 Linux thinclients

    I have checked the forums and thought I had similar problems with some people who resolved them by changing the MTU
    value of the PPPoE configuration for the WAN link but that did not help me my MTU is properly set at 1492 (in fact if I change
    to it to a different value it fails to connect ).

    Any help would be great! Thanks!

  • Just placing here the solution for this problem after so many months. Basically it was an MTU issue, even though im using a
    PPPoE to PPPoA bridge one would assume I would need to set the mtu to 1492. But that would not help, I had to set
    the MTU down to 1454 so that everything finally worked normally on my linux machines. Oddly the windows machines
    were never affected no matter what value was set.