Awww NUTs! (Network UPS Tools) detects UPS, but won't display telemetry



  • Awww NUTs! (Network UPS Tools) detects UPS, but won't display telemetry "Failed to retrieve status"

    Hi everyone!!

    I'm running pfSense 2.4.2-RELEASE and just installed NUT to monitor and control my APC BE550G Back-UPS , connected via USB, but all I get is the error message "Failed to retrieve status".

    When this UPS is connected to my web-server, I can get telemetry through WebMin, so I'm pretty sure that rules out an issue with the UPS and its firmware, and the USB cable. Also, when plugged in to my pfSense firewall, doing usbconfig does in fact list the UPS, so the firewall is detecting the UPS. Additionally, while logged in to the shell, it periodically displays "UPS <ups name="">is unavailable"

    I feel like it's probably a very simple thing that I've over looked - please forgive my ignorance!




    </ups>



  • Not expert but NETWORK UPS tools suggests it expects the UPS on the ethernet?  U sure NUT understands USB?  do u need to tell it specifically (UPS is on USB), does it ask you what IP/alias the UPS is at?



  • Hi SammyWoo

    Thanks for the reply.

    Yes, the NUT service works with USB. It is set for "local USB" and the recommended driver of USBHID is selected.




  • What is in the log?
    With UPS not connected I see the same "Failed to retrieve status" on UPS Status page and lots of messages from upsd and upsmon in the log.
    What is the part number of the cable you have? Something like 940-XXXX
    Do you have the same software (NUT) on your web server where you tested your UPS?


Log in to reply