Filecopy over VLANs breaks

  • Hey,

    I currently have a strange Problem. On a Setup with several VLANS I encounter the Problem that if a PC from VLAN1 transfers a file from a PC in VLAN2 via SMB it randomly stops copying. In a Wireshar I only see some TCP Resets.

    The Problem is clearly somehow the pfSense in between, if both PCs are in the same VLAN everything is smooth.

    I tried around with TCP Offlloading on/off and so on but unfortunately it doesnt help. Its not just SMB related, also happens with webdav and FTP so in general a file problem. Normal web connections and Download from WAN are not affected at all, Streaming and downloading large files from wan does not show this behavior.

    I know it's not easy to tell but if anybody have a any hint what could cause this strange behavior; Apreciated!


  • LAYER 8 Global Moderator

    So your seeing RSTS

    How does that have to do with pfsense - pfsense is not going to send a RST.

    Post up the pcap of these RSTs your seeing…

  • Hi,

    I'm not 100% what exactly it is, the RST Problem was just a clue but later showed thats not the case those RST were just random unrelated, it looks like something with the TCP Window but also this not for sure. Im totaly in the dark right now. Only thing I know if instead of the pfSense I just use a routing switch to connect both hosts it works. Back to pfSense routing and error is back. The Switch routing is not a option here so this is why I need to figure out whats acutally happening.

    The copy progress seems random, like in attached dump first it start with full transfer speed but at < 1s it dropped to 0b/s after 4.14s it restart the SMB by new request and copy again.

    The attached log shows client trying to copy from  Client Vlan 113, Server in 102.

    It doesnt matter if the Server is a linux Samba or a windows machine.


    It's not limited to SMB, a test with a HTTP Transfer did show the same problem.

    As said. I have currently no clue and just hoping anybody have seen similar issues before and thankful for any idea.

    Thanks in advance

  • LAYER 8 Global Moderator

    There are huge amounts of dup ack, and retrans..

    This file

    Can you draw up your network?  There is clearly something wrong here..

    A few retrans, ok a handful of dupes..  Is there wireless involved anywhere?

    That is just a crazy amount of dupes..

  • Galactic Empire

    What's your hardware ?

  • Hey,

    yes thats weird.

    The Setup uses pfsense running bare metal on two Dell R330 (Intel Xeon CPU E3-1240 with intel server NICs) with a carp setup. Each R330 with 4 Interfaces trunked as LACP (2xWAN, 2x LAN) to the switching hardware. Here we use different juniper switches like ex2200.

    In our testing we just had the server on the same switch as the pfsense but different VLAN as the client, Client is connected to another switch. Yes there is wifi but not involved in this issue, wifi is another vlan.

    Already tried to disable all the offloading features.

Log in to reply