Sem acesso a internet após mudança de máscara



  • Boa tarde pessoal

    Por falta de ips na minha rede tive que alterar a máscara de rede do meu servidor dhcp de 255.255.255.0 para 255.255.254.0 utilizando desta forma as redes 192.168.0.1 a 192.168.1.255. Ocorre que venho notando que os ips da faixa 192.168.1 não conseguem acessar internet, ou as vezes abre um site e outros não. O gateway do meu pfsense é 192.168.0.249 e mudei ele na lan para a mascara 23 então fico 192.168.0.249/23. O que pode estar acontecendo.  Será que deixei de fazer alguma configuração no pfsense ou é algo no meu servidor de dhcp ou dns?



  • Aparentemente, está tudo certo. Lembrou de alterar a máscara na interface LAN também?



  • Sim alterei. Estranho é que as vezes o usuário consegue acessar a página mas quando tente de novo não acessa. Quanto pingo o endereço da página temos a resposta porém quando vamos acessar no browser não acessa.



  • Veja nos logs se o firewall está bloqueando e qual regra que causa isso. Na aba da interface LAN veja se o "Block private networks and loopback addresses" está desmarcado.



  • Esta opção está desmarcada vou ver as regras



  • Li com mais atenção isso aqui: "O gateway do meu pfsense é 192.168.0.249 e mudei ele na lan para a mascara 23 então fico 192.168.0.249/23"

    Você não mencionou suas interfaces, mas ficou dando a impressão que a LAN e a WAN estão no mesmo segmento (192.168.0.0/23), é isso? LAN e WAN devem estar em segmentos diferentes, senão problemas como o que você está experimentando vão ser uma constante na sua vida…

    Um breve descrição da configuração das interfaces do pfsense também ajudariam na identificação e solução do problema.



  • A Lan é 192.168.0.249/23 não a WAN ok.
    Resolvi o problema. limpei o cache do Squid e tudo voltou ao normal. Valeu galera


Log in to reply